summaryrefslogtreecommitdiffhomepage
path: root/tests/custom/CMakeLists.txt
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2021-04-26 18:56:41 +0200
committerJo-Philipp Wich <jo@mein.io>2021-04-27 12:17:35 +0200
commit6def9fcf1cdec117866877aa5e7241e23bdc8c23 (patch)
treeee7a99bb9284a4fbf3050ab8bd0bfb41b6160e06 /tests/custom/CMakeLists.txt
parentd5dd183f3622002fbc4ae175045a3ebce4eeeb05 (diff)
tests: pass ucode library path through environment
This is required for out-of-tree builds where the *.so file location cannot be derived from the path of the ucode executable. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'tests/custom/CMakeLists.txt')
-rw-r--r--tests/custom/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/custom/CMakeLists.txt b/tests/custom/CMakeLists.txt
index d56cb99..c8007a0 100644
--- a/tests/custom/CMakeLists.txt
+++ b/tests/custom/CMakeLists.txt
@@ -3,7 +3,10 @@ ADD_TEST(
COMMAND run_tests.sh
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
)
-SET_PROPERTY(TEST custom APPEND PROPERTY ENVIRONMENT "UCODE_BIN=valgrind --quiet --leak-check=full $<TARGET_FILE:ucode>")
+SET_PROPERTY(TEST custom APPEND PROPERTY ENVIRONMENT
+ "UCODE_BIN=valgrind --quiet --leak-check=full $<TARGET_FILE:ucode>"
+ "UCODE_LIB=${CMAKE_BINARY_DIR}"
+)
IF(CMAKE_C_COMPILER_ID STREQUAL "Clang")
ADD_TEST(
@@ -12,5 +15,8 @@ IF(CMAKE_C_COMPILER_ID STREQUAL "Clang")
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
)
- SET_PROPERTY(TEST custom-san APPEND PROPERTY ENVIRONMENT "UCODE_BIN=$<TARGET_FILE:ucode-san>")
+ SET_PROPERTY(TEST custom-san APPEND PROPERTY ENVIRONMENT
+ "UCODE_BIN=$<TARGET_FILE:ucode-san>"
+ "UCODE_LIB=${CMAKE_BINARY_DIR}"
+ )
ENDIF()