summaryrefslogtreecommitdiffhomepage
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2021-03-19 17:04:29 +0100
committerJo-Philipp Wich <jo@mein.io>2021-04-23 00:42:30 +0200
commitdf73b25de218833588a9770f6beb9e4a2908bcb7 (patch)
treedc28a1b956ad7699a13914f896f37295242a4c1e /tests/CMakeLists.txt
parent41d33d0b2b09efb7b3cddefa2793cf2133a7b5dc (diff)
tests: add more tests
* add cram based tests * test under either valgrind or LLVM sanitizers * add libFuzzer template Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..aed0100
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,6 @@
+ADD_SUBDIRECTORY(cram)
+ADD_SUBDIRECTORY(custom)
+
+IF(CMAKE_C_COMPILER_ID STREQUAL "Clang")
+ ADD_SUBDIRECTORY(fuzz)
+ENDIF()