summaryrefslogtreecommitdiffhomepage
path: root/openwrt
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2023-07-11 15:28:49 +0200
committerJo-Philipp Wich <jo@mein.io>2023-07-12 00:18:43 +0200
commitb9d8f06377608069c2c4ec27cd419ce89a393762 (patch)
tree000047647f59481e801b9e61c1a927a27f760424 /openwrt
parentc7d84aae09691a99ae3db427c0b2463732ef84f4 (diff)
ci: switch to official openwrt/gh-action-sdk
Utilize the official openwrt/gh-action-sdk CI actions to test-build OpenWrt packages. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/ucode/Makefile240
1 files changed, 240 insertions, 0 deletions
diff --git a/openwrt/ucode/Makefile b/openwrt/ucode/Makefile
new file mode 100644
index 0000000..2158dba
--- /dev/null
+++ b/openwrt/ucode/Makefile
@@ -0,0 +1,240 @@
+#
+# Copyright (C) 2020-2023 Jo-Philipp Wich <jo@mein.io>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ucode
+PKG_VERSION:=$(if $(DUMP),x,$(shell git log -1 --date=format:"%Y-%m-%d" --format=%cd))
+PKG_ABI_VERSION:=$(if $(DUMP),x,$(shell git log -1 --date=format:"%Y%m%d" --format=%cd))
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+CMAKE_SOURCE_DIR=$(CURDIR)/../../
+CMAKE_OPTIONS += -DSOVERSION=$(PKG_ABI_VERSION)
+CMAKE_HOST_OPTIONS += \
+ -DSOVERSION=$(PKG_ABI_VERSION) \
+ -DFS_SUPPORT=ON \
+ -DMATH_SUPPORT=ON \
+ -DNL80211_SUPPORT=OFF \
+ -DRESOLV_SUPPORT=OFF \
+ -DRTNL_SUPPORT=OFF \
+ -DSTRUCT_SUPPORT=ON \
+ -DUBUS_SUPPORT=OFF \
+ -DUCI_SUPPORT=OFF \
+ -DULOOP_SUPPORT=OFF
+
+
+define Package/ucode/default
+ SUBMENU:=ucode
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Tiny scripting and templating language
+endef
+
+define Package/ucode
+ $(Package/ucode/default)
+ DEPENDS:=+libucode
+endef
+
+define Package/ucode/description
+ ucode is a tiny script interpreter featuring an ECMAScript oriented
+ script language and Jinja-inspired templating.
+endef
+
+
+define Package/libucode
+ $(Package/ucode/default)
+ SUBMENU:=
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE+= (library)
+ ABI_VERSION:=$(PKG_ABI_VERSION)
+ DEPENDS:=+libjson-c
+endef
+
+define Package/libucode/description
+ The libucode package provides the shared runtime library for the ucode interpreter.
+endef
+
+
+define Package/ucode-mod-fs
+ $(Package/ucode/default)
+ TITLE+= (filesystem module)
+ DEPENDS:=ucode
+endef
+
+define Package/ucode-mod-fs/description
+ The filesystem plugin module allows interaction with the local file system.
+endef
+
+
+define Package/ucode-mod-math
+ $(Package/ucode/default)
+ TITLE+= (math module)
+ DEPENDS:=ucode
+endef
+
+define Package/ucode-mod-math/description
+ The math plugin provides access to various <math.h> procedures.
+endef
+
+
+define Package/ucode-mod-nl80211
+ $(Package/ucode/default)
+ TITLE+= (nl80211 module)
+ DEPENDS:=ucode +libnl-tiny +libubox
+endef
+
+define Package/ucode-mod-nl80211/description
+ The nl80211 plugin provides access to the Linux wireless 802.11 netlink API.
+endef
+
+
+define Package/ucode-mod-resolv
+ $(Package/ucode/default)
+ TITLE+= (resolv module)
+ DEPENDS:=ucode
+endef
+
+define Package/ucode-mod-resolv/description
+ The resolv plugin implements simple DNS resolving.
+endef
+
+
+define Package/ucode-mod-rtnl
+ $(Package/ucode/default)
+ TITLE+= (rtnl module)
+ DEPENDS:=ucode +libnl-tiny +libubox
+endef
+
+define Package/ucode-mod-rtnl/description
+ The rtnl plugin provides access to the Linux routing netlink API.
+endef
+
+
+define Package/ucode-mod-struct
+ $(Package/ucode/default)
+ TITLE+= (struct module)
+ DEPENDS:=ucode
+endef
+
+define Package/ucode-mod-struct/description
+ The struct plugin implements Python 3 compatible struct.pack/unpack functionality.
+endef
+
+
+define Package/ucode-mod-ubus
+ $(Package/ucode/default)
+ TITLE+= (ubus module)
+ DEPENDS:=ucode +libubus +libblobmsg-json
+endef
+
+define Package/ucode-mod-ubus/description
+ The ubus module allows ucode template scripts to enumerate and invoke ubus
+ procedures.
+endef
+
+
+define Package/ucode-mod-uci
+ $(Package/ucode/default)
+ TITLE+= (uci module)
+ DEPENDS:=ucode +libuci
+endef
+
+define Package/ucode-mod-uci/description
+ The uci module allows templates to read and modify uci configuration.
+endef
+
+
+define Package/ucode-mod-uloop
+ $(Package/ucode/default)
+ TITLE+= (uloop module)
+ DEPENDS:=ucode +libubox
+endef
+
+define Package/ucode-mod-uloop/description
+ The uloop module allows ucode scripts to interact with OpenWrt uloop event
+ loop implementation.
+endef
+
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include/ucode
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/ucode/*.h $(1)/usr/include/ucode/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libucode.so* $(1)/usr/lib/
+endef
+
+
+define Package/ucode/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/u* $(1)/usr/bin/
+endef
+
+define Package/libucode/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libucode.so.* $(1)/usr/lib/
+endef
+
+define Package/ucode-mod-fs/install
+ $(INSTALL_DIR) $(1)/usr/lib/ucode
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/fs.so $(1)/usr/lib/ucode/
+endef
+
+define Package/ucode-mod-math/install
+ $(INSTALL_DIR) $(1)/usr/lib/ucode
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/math.so $(1)/usr/lib/ucode/
+endef
+
+define Package/ucode-mod-nl80211/install
+ $(INSTALL_DIR) $(1)/usr/lib/ucode
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/nl80211.so $(1)/usr/lib/ucode/
+endef
+
+define Package/ucode-mod-resolv/install
+ $(INSTALL_DIR) $(1)/usr/lib/ucode
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/resolv.so $(1)/usr/lib/ucode/
+endef
+
+define Package/ucode-mod-rtnl/install
+ $(INSTALL_DIR) $(1)/usr/lib/ucode
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/rtnl.so $(1)/usr/lib/ucode/
+endef
+
+define Package/ucode-mod-struct/install
+ $(INSTALL_DIR) $(1)/usr/lib/ucode
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/struct.so $(1)/usr/lib/ucode/
+endef
+
+define Package/ucode-mod-ubus/install
+ $(INSTALL_DIR) $(1)/usr/lib/ucode
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/ubus.so $(1)/usr/lib/ucode/
+endef
+
+define Package/ucode-mod-uci/install
+ $(INSTALL_DIR) $(1)/usr/lib/ucode
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/uci.so $(1)/usr/lib/ucode/
+endef
+
+define Package/ucode-mod-uloop/install
+ $(INSTALL_DIR) $(1)/usr/lib/ucode
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/uloop.so $(1)/usr/lib/ucode/
+endef
+
+$(eval $(call BuildPackage,libucode))
+$(eval $(call BuildPackage,ucode))
+$(eval $(call BuildPackage,ucode-mod-fs))
+$(eval $(call BuildPackage,ucode-mod-math))
+$(eval $(call BuildPackage,ucode-mod-nl80211))
+$(eval $(call BuildPackage,ucode-mod-resolv))
+$(eval $(call BuildPackage,ucode-mod-rtnl))
+$(eval $(call BuildPackage,ucode-mod-struct))
+$(eval $(call BuildPackage,ucode-mod-ubus))
+$(eval $(call BuildPackage,ucode-mod-uci))
+$(eval $(call BuildPackage,ucode-mod-uloop))
+$(eval $(call HostBuild))