summaryrefslogtreecommitdiffhomepage
path: root/debian/control
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2022-03-20 15:18:27 +0000
committerJo-Philipp Wich <jo@mein.io>2022-03-31 10:01:49 +0200
commitf4042854d3a5a75ad34f856d0d12d5c74e751488 (patch)
tree0e85cc0f39a2a9acf0469816255cb2323c4a2ebb /debian/control
parent8134e2509d6aa201e46eaae4f7eb55bfbbf758ee (diff)
debian: Add package definition
This adds Debian packages for the ucode interpreter, the runtime library, development headers and extension modules. Fixes: #55 Signed-off-by: Paul Spooren <mail@aparcar.org> [split into multiple packages, pass SOVERSION to the build] Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control70
1 files changed, 70 insertions, 0 deletions
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..5e9d7f3
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,70 @@
+Source: ucode
+Maintainer: Paul Spooren <mail@aparcar.org>
+Section: misc
+Priority: optional
+Standards-Version: 0.0.20220322-1
+Build-Depends: debhelper-compat (= 12), libjson-c-dev
+
+Package: ucode
+Architecture: any
+Multi-Arch: foreign
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Tiny scripting language with ECMA script syntax
+ Ucode is a tiny script language featuring ECMA script syntax, builtin JSON
+ support and templating using Jinja inspired markup. The ucode VM is provided
+ as shared library with a C API allowing embedding into host applications and
+ interchanging data between ucode and C programs. The ucode VM can also be
+ used as stand-alone multi purpose scripting language through the provided
+ ucode cli interpreter.
+ .
+ This package contains the ucode command line interpreter, which is required
+ to develop, debug and precompile ucode scripts.
+
+Package: ucode-modules
+Architecture: any
+Multi-Arch: foreign
+Depends: libucode (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
+Description: Extension modules for the ucode language
+ Ucode is a tiny script language featuring ECMA script syntax, builtin JSON
+ support and templating using Jinja inspired markup. The ucode VM is provided
+ as shared library with a C API allowing embedding into host applications and
+ interchanging data between ucode and C programs. The ucode VM can also be
+ used as stand-alone multi purpose scripting language through the provided
+ ucode cli interpreter.
+ .
+ This package contains various native ucode extensions which provide further
+ functionality such as filesystem access, math functions etc.
+
+Package: libucode
+Architecture: any
+Multi-Arch: same
+Pre-Depends: ${misc:Pre-Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Section: libs
+Description: Shared library for the ucode interpreter
+ Ucode is a tiny script language featuring ECMA script syntax, builtin JSON
+ support and templating using Jinja inspired markup. The ucode VM is provided
+ as shared library with a C API allowing embedding into host applications and
+ interchanging data between ucode and C programs. The ucode VM can also be
+ used as stand-alone multi purpose scripting language through the provided
+ ucode cli interpreter.
+ .
+ This package contains the libucode VM runtime, it should not be needed to
+ install it explicitly.
+
+Package: libucode-dev
+Architecture: any
+Multi-Arch: same
+Depends: libucode (= ${binary:Version}), libc6-dev|libc-dev, ${misc:Depends}
+Section: libdevel
+Description: Development files for the ucode VM library
+ Ucode is a tiny script language featuring ECMA script syntax, builtin JSON
+ support and templating using Jinja inspired markup. The ucode VM is provided
+ as shared library with a C API allowing embedding into host applications and
+ interchanging data between ucode and C programs. The ucode VM can also be
+ used as stand-alone multi purpose scripting language through the provided
+ ucode cli interpreter.
+ .
+ This package contains the development header to interface with the libucode
+ VM runtime, which is required when developing programs or extensions using
+ the ucode C API.