summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2022-01-18 15:28:00 +0100
committerJo-Philipp Wich <jo@mein.io>2022-01-18 15:28:00 +0100
commit03b6a8efc1834a4114f0d11e1a7cecff3242b305 (patch)
treef3b620b35ca765f32af4dd10aa29794be805c53a /CMakeLists.txt
parent61d0a34fb7501a1f8aa43cfa1063c8a7ca1fb1d2 (diff)
syntax: drop legacy syntax support
Drop support for the `local` keyword and `delete` function calls. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0621d51..7c84fc3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,8 +28,6 @@ OPTION(NL80211_SUPPORT "Wireless Netlink plugin support" ON)
OPTION(RESOLV_SUPPORT "NS resolve plugin support" ON)
OPTION(STRUCT_SUPPORT "Struct plugin support" ON)
-OPTION(LEGACY_SUPPORT "Support deprecated syntax features" ON)
-
SET(LIB_SEARCH_PATH "${CMAKE_INSTALL_PREFIX}/lib/ucode/*.so:${CMAKE_INSTALL_PREFIX}/share/ucode/*.uc:./*.so:./*.uc" CACHE STRING "Default library search path")
STRING(REPLACE ":" "\", \"" LIB_SEARCH_DEFINE "${LIB_SEARCH_PATH}")
ADD_DEFINITIONS(-DLIB_SEARCH_PATH="${LIB_SEARCH_DEFINE}")
@@ -46,10 +44,6 @@ ELSE()
ADD_DEFINITIONS(-DNDEBUG)
ENDIF()
-IF(NOT LEGACY_SUPPORT)
- ADD_DEFINITIONS(-DNO_LEGACY)
-ENDIF()
-
INCLUDE(FindPkgConfig)
PKG_CHECK_MODULES(JSONC json-c json)
IF(JSONC_FOUND)