summaryrefslogtreecommitdiffhomepage
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index af2f621..6d806e0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -29,10 +29,10 @@ tinyproxy_SOURCES = \
buffer.c buffer.h \
child.c child.h \
common.h \
+ conf-tokens.c conf-tokens.h \
conf.c conf.h \
conns.c conns.h \
daemon.c daemon.h \
- hashmap.c hashmap.h \
heap.c heap.h \
html-error.c html-error.h \
http-message.c http-message.h \
@@ -44,14 +44,27 @@ tinyproxy_SOURCES = \
text.c text.h \
main.c main.h \
utils.c utils.h \
- vector.c vector.h \
upstream.c upstream.h \
basicauth.c basicauth.h \
base64.c base64.h \
+ sblist.c sblist.h \
+ hsearch.c hsearch.h \
+ orderedmap.c orderedmap.h \
+ loop.c loop.h \
+ mypoll.c mypoll.h \
connect-ports.c connect-ports.h
EXTRA_tinyproxy_SOURCES = filter.c filter.h \
reverse-proxy.c reverse-proxy.h \
transparent-proxy.c transparent-proxy.h
tinyproxy_DEPENDENCIES = @ADDITIONAL_OBJECTS@
-tinyproxy_LDADD = @ADDITIONAL_OBJECTS@
+tinyproxy_LDADD = @ADDITIONAL_OBJECTS@ -lpthread
+
+if HAVE_GPERF
+conf-tokens.c: conf-tokens-gperf.inc
+conf-tokens-gperf.inc: conf-tokens.gperf
+ $(GPERF) $< > $@
+endif
+
+EXTRA_DIST = conf-tokens.gperf
+