summaryrefslogtreecommitdiffhomepage
path: root/docs/man8/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/man8/Makefile.am')
-rw-r--r--docs/man8/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/docs/man8/Makefile.am b/docs/man8/Makefile.am
index 1bd0ffa..5e2f390 100644
--- a/docs/man8/Makefile.am
+++ b/docs/man8/Makefile.am
@@ -7,6 +7,8 @@ else
A2X_ARGS = -d manpage -f manpage -L
endif
+ASCIIDOCTOR_ARGS = -b manpage
+
man_MANS = \
$(MAN8_FILES:.txt=.8)
@@ -14,7 +16,11 @@ man_MANS = \
if HAVE_A2X
$(AM_V_GEN) $(A2X) $(A2X_ARGS) $<
else
- @echo "*** a2x (asciidoc) is required to regenerate $(@) ***"; exit 1;
+if HAVE_ASCIIDOCTOR
+ $(AM_V_GEN) $(ASCIIDOCTOR) $(ASCIIDOCTOR_ARGS) $<
+else
+ @echo "*** a2x (asciidoc) or asciidoctor is required to regenerate $(@) ***"; exit 1;
+endif
endif
CLEANFILES = \