summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7de6087..3849383 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,7 +141,7 @@ AC_HEADER_STDC
AC_HEADER_TIME
AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS([sys/ioctl.h alloca.h memory.h malloc.h sysexits.h \
- values.h])
+ values.h poll.h])
dnl Checks for libary functions
AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
@@ -204,6 +204,22 @@ fi #manpage_support_enabled
AM_CONDITIONAL(HAVE_POD2MAN, test "x$POD2MAN" != "x" -a "x$POD2MAN" != "xno")
+AC_PATH_PROG(GPERF, gperf, no)
+AM_CONDITIONAL(HAVE_GPERF, test "x$GPERF" != "x" -a "x$GPERF" != "xno")
+AH_TEMPLATE([HAVE_GPERF],
+ [Whether you have gperf installed for faster config parsing.])
+
+if test "x$GPERF" != "x" -a "x$GPERF" != "xno" ; then
+ AS_ECHO_N(["checking whether gperf is recent enough... "])
+ if "$GPERF" < src/conf-tokens.gperf >/dev/null 2>&1 ; then
+ AS_ECHO("yes")
+ AC_DEFINE(HAVE_GPERF)
+ else
+ AM_CONDITIONAL(HAVE_GPERF, false)
+ AS_ECHO("no")
+ fi
+fi
+
AC_CONFIG_FILES([
Makefile
src/Makefile