summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1893945..3990c2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -251,9 +251,6 @@ AM_CONDITIONAL(HAVE_XSLTPROC, test "x$XSLTPROC" != "xno")
# Check for asciidoc
AC_PATH_PROG(A2X, a2x, no)
AM_CONDITIONAL(HAVE_A2X, test "x$A2X" != "xno")
-if test x"$A2X" = x"no"; then
- AC_MSG_ERROR([Test for asciidoc failed. See the file 'INSTALL' for help.])
-fi
# checking xmllint
AC_PATH_PROG(XMLLINT, xmllint, no)
@@ -287,3 +284,20 @@ tests/scripts/Makefile
])
AC_OUTPUT
+
+# the manpages are shipped in the release tarball and we don't want them to
+# get regenerated if a2x is not available. the intermediate files from
+# AC_CONFIG_FILES are created with config.status, which is created at configure
+# runtime, so we need to touch them after config.status terminated to prevent
+# make from rebuild them.
+
+if test "x$A2X" = "xno"; then
+ touch docs/man5/tinyproxy.conf.txt
+ touch docs/man8/tinyproxy.txt
+ if test -e docs/man5/tinyproxy.conf.5 ; then
+ touch docs/man5/tinyproxy.conf.5
+ fi
+ if test -e docs/man8/tinyproxy.8 ; then
+ touch docs/man8/tinyproxy.8
+ fi
+fi