summaryrefslogtreecommitdiffhomepage
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRobert James Kaes <rjkaes@users.sourceforge.net>2000-09-11 23:37:01 +0000
committerRobert James Kaes <rjkaes@users.sourceforge.net>2000-09-11 23:37:01 +0000
commit06281b78980fe586f72a7a7b58fd777bacdcf667 (patch)
tree033931cca692bb22b08d37328e2835d116dc21ed /src/Makefile.am
parentad28ae027aec99ec86bcd0ea3a7386fa5098e66a (diff)
Modified to include all the files needed to build tinyproxy, plus the
special targets for building the LEX and YACC files. (Also included the GNU license.)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am33
1 files changed, 30 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0c31944..87a5b7d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,26 @@
+# $Id: Makefile.am,v 1.3 2000-09-11 23:37:01 rjkaes Exp $
+#
+#
+#
+# Copyright (C) 2000 Robert James Kaes (rjkaes@flarenet.com)
+#
+# This program is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; either version 2, or (at your option) any
+# later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+
+YFLAGS = @YFLAGS@
+
bin_PROGRAMS = tinyproxy
-tinyproxy_SOURCES = config.h \
+
+tinyproxy_SOURCES = \
buffer.c buffer.h \
- conns.c conns.h \
dnscache.c dnscache.h \
log.c log.h \
reqs.c reqs.h \
@@ -10,6 +29,11 @@ tinyproxy_SOURCES = config.h \
uri.c uri.h \
utils.c utils.h \
anonymous.c anonymous.h \
+ stats.c stats.h \
+ thread.c thread.h \
+ grammar.y scanner.l \
+ acl.c acl.h \
+ ternary.c ternary.h \
regexp.h
tinyproxy_LDADD = @LIBOBJS@
@@ -17,4 +41,7 @@ tinyproxy_LDADD = @LIBOBJS@
EXTRA_DIST = gnuregex.c gnuregex.h \
filter.c filter.h
-LDADD = @LIBOBJS
+EXTRA_tinyproxy_SOURCES = grammar.h
+
+scanner.c: scanner.l grammar.h
+ $(LEX) $(AM_LFLAGS) $(LFLAGS) -i $< && mv $(LEX_OUTPUT_ROOT).c $@