summaryrefslogtreecommitdiffhomepage
path: root/docs/man8/Makefile.am
diff options
context:
space:
mode:
authorrofl0r <rofl0r@users.noreply.github.com>2020-08-19 22:33:59 +0100
committerrofl0r <rofl0r@users.noreply.github.com>2020-08-19 22:45:37 +0100
commita547a298c77c331061511a6befffc346c1a44a05 (patch)
tree76141bddc458708cc4916e983e165cf6420267eb /docs/man8/Makefile.am
parent3fa53f866019aa5794a3a67e2e476c26918ac4df (diff)
generate manpages with pod2man instead of a2x/asciidoc(tor)
it turned out that the upstream section in tinyproxy.conf.5 wasn't rendered properly, because in asciidoc items following a list item are always explicitly appended to the last list item. after several hours of finding a workaround, it was decided to change the manpage generator to pod2man instead. as pod2man ships together with any perl base install, it should be available on almost every UNIX system, unlike asciidoc which requires installation of a huge set of dependencies (more than 1.3 GB on Ubuntu 16.04), and the replacement asciidoctor requires a ruby installation plus a "gem" (which is by far better than asciidoc, but still more effort than using the already available pod2man). tinyproxy's hard requirement of a2x (asciidoctor) for building from source caused rivers of tears (and dozens of support emails/issues) in the past, but finally we get rid of it. a tool such as a2x with its XML based bloat- technology isn't really suited to go along with a supposedly lightweight C program. if it ever turns out that even pod2man is too heavy a dependency, we could still write our own replacement in less than 50 lines of awk, as the pod syntax is very low level and easy to parse.
Diffstat (limited to 'docs/man8/Makefile.am')
-rw-r--r--docs/man8/Makefile.am28
1 files changed, 9 insertions, 19 deletions
diff --git a/docs/man8/Makefile.am b/docs/man8/Makefile.am
index 0d1eda1..d2d7e19 100644
--- a/docs/man8/Makefile.am
+++ b/docs/man8/Makefile.am
@@ -1,35 +1,25 @@
if HAVE_MANPAGE_INTEREST
-MAN8_FILES = \
+MAN8_FILES = \
tinyproxy.txt
endif
-if HAVE_XMLLINT
-A2X_ARGS = -d manpage -f manpage
-else
-A2X_ARGS = -d manpage -f manpage -L
-endif
-
-ASCIIDOCTOR_ARGS = -b manpage
+M_SECTION=8
+M_NAME=TINYPROXY
man_MANS = \
$(MAN8_FILES:.txt=.8)
.txt.8:
-if HAVE_A2X
- $(AM_V_GEN) $(A2X) $(A2X_ARGS) $<
+if HAVE_POD2MAN
+ $(AM_V_GEN) $(POD2MAN) --center="Tinyproxy manual" \
+ --section=$(M_SECTION) --name=$(M_NAME) --release="Version @VERSION@" \
+ $< > $@
else
-if HAVE_ASCIIDOCTOR
- $(AM_V_GEN) $(ASCIIDOCTOR) $(ASCIIDOCTOR_ARGS) $<
-else
- @echo "*** a2x (asciidoc) or asciidoctor is required to regenerate $(@) ***"; exit 1;
-endif
+ @echo "*** pod2man is required to regenerate $(@) ***"; exit 1;
endif
MAINTAINERCLEANFILES = \
$(MAN8_FILES:.txt=.8)
-CLEANFILES = \
- $(MAN8_FILES:.txt=.xml)
-
-EXTRA_DIST= \
+EXTRA_DIST = \
$(MAN8_FILES:.txt=.8)