summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorrofl0r <retnyg@gmx.net>2016-12-21 21:09:42 +0000
committerrofl0r <retnyg@gmx.net>2016-12-21 21:16:06 +0000
commitc98f1cd25a4e9bdd48e3fe463e04b347fd3b7ccc (patch)
tree625adb166eb42944e89a6ed54480aa1ea10ab2fe /configure.ac
parentc3cc308cc8ae31910130da92c3ac59354e3bc7a7 (diff)
configure: remove checks for standard types
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index f9b9891..39e303f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,19 +164,6 @@ AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS([sys/ioctl.h alloca.h memory.h malloc.h sysexits.h \
values.h])
-dnl Checks for types
-AC_TYPE_SIZE_T
-AC_TYPE_PID_T
-AC_UNP_CHECK_TYPE(uint8_t, unsigned char)
-AC_UNP_CHECK_TYPE(int16_t, short)
-AC_UNP_CHECK_TYPE(uint16_t, unsigned short)
-AC_UNP_CHECK_TYPE(int32_t, int)
-AC_UNP_CHECK_TYPE(uint32_t, unsigned int)
-AC_UNP_CHECK_TYPE(ssize_t, int)
-AC_UNP_CHECK_TYPE(socklen_t, unsigned int)
-AC_UNP_CHECK_TYPE(in_addr_t, uint32_t)
-
-
dnl Checks for libary functions
AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
AC_FUNC_MALLOC