summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorrofl0r <retnyg@gmx.net>2016-12-21 21:06:13 +0000
committerrofl0r <retnyg@gmx.net>2016-12-21 21:16:06 +0000
commitc3cc308cc8ae31910130da92c3ac59354e3bc7a7 (patch)
tree4c23de7cb6948aa02be2f1c8153c4d37b9f3665a /configure.ac
parent81a93f9e4fc4a6f134749ea077b797687a12abf9 (diff)
configure: remove checks for standard POSIX funcs
addresses #65
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index e148077..f9b9891 100644
--- a/configure.ac
+++ b/configure.ac
@@ -182,14 +182,9 @@ AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
AC_FUNC_MALLOC
AC_FUNC_REALLOC
-AC_CHECK_FUNCS([gethostname inet_ntoa memchr memset select socket strcasecmp \
- strchr strdup strerror strncasecmp strpbrk strstr strtol])
-AC_CHECK_FUNCS([isascii memcpy memmove setrlimit ftruncate regcomp regexec])
+AC_CHECK_FUNCS([inet_ntoa strdup])
AC_CHECK_FUNCS([strlcpy strlcat setgroups])
-AC_CHECK_FUNCS([time rand srand])
-
-
dnl Enable extra warnings
DESIRED_FLAGS="-fdiagnostics-show-option -Wall -Wextra -Wno-unused-parameter -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -Wfloat-equal -Wundef -Wformat=2 -Wlogical-op -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Waggregate-return -Winit-self -Wpacked --std=c89 -ansi -pedantic -Wno-overlength-strings -Wc++-compat -Wno-long-long -Wno-overlength-strings -Wdeclaration-after-statement -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-qual -Wcast-align -Wwrite-strings -Wp,-D_FORTIFY_SOURCE=2 -fno-common"
@@ -212,11 +207,6 @@ dnl
dnl Make sure we can actually handle the "--with-*" and "--enable-*" stuff.
dnl
-dnl Handle the REGEX library
-if test x"$ac_cv_func_regexec" != x"yes"; then
- AC_MSG_ERROR([Could not locate the regexec() function])
-fi
-
dnl
dnl Substitute the variables into the various Makefiles
dnl