summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorrofl0r <rofl0r@users.noreply.github.com>2020-08-11 14:52:16 +0100
committerrofl0r <rofl0r@users.noreply.github.com>2020-08-11 15:25:02 +0100
commitc2d4114427421864f9152856c6e2b4b9ff6d83dd (patch)
treec2011fa6d3c36c57e15e007bc51d4a32021e95bb /configure.ac
parent0b9a74c29036f9215b2b97a301b7b25933054302 (diff)
add support for asciidoctor to generate manpages
asciidoctor is a modern replacement for asciidoc and much more lightweight, issuing "apt-get install asciidoc" on ubuntu 16.04 results in an attempt to install more than 1.3 GB of dependencies.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6ddbcc0..623d9a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -181,6 +181,10 @@ AM_CONDITIONAL(HAVE_XSLTPROC, test "x$XSLTPROC" != "xno")
AC_PATH_PROG(A2X, a2x, no)
AM_CONDITIONAL(HAVE_A2X, test "x$A2X" != "xno")
+# Check for asciidoctor
+AC_PATH_PROG(ASCIIDOCTOR, asciidoctor, no)
+AM_CONDITIONAL(HAVE_ASCIIDOCTOR, test "x$ASCIIDOCTOR" != "xno")
+
# checking xmllint
AC_PATH_PROG(XMLLINT, xmllint, no)
if test "x$XMLLINT" != "xno"; then
@@ -221,7 +225,7 @@ AC_OUTPUT
# runtime, so we need to touch them after config.status terminated to prevent
# make from rebuild them.
-if test "x$A2X" = "xno"; then
+if test "x$A2X" = "xno" -a "x$HAVE_ASCIIDOCTOR" = "xno" ; then
touch docs/man5/tinyproxy.conf.txt
touch docs/man8/tinyproxy.txt
if test -e docs/man5/tinyproxy.conf.5 ; then