summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2018-09-04 01:23:01 +0200
committerMichael Adam <obnox@samba.org>2018-09-05 00:56:31 +0200
commit9f4ed46c0adf6ce6cb8dd44aff611448b64a37a7 (patch)
treee91782c1343270743cd5b8376855019d50f8a7b7 /configure.ac
parenta662c11b8d106e0a2f3379b89739ed4770c5bbd3 (diff)
build: add new version mechanism based on VERSION file and a version.sh script
If this is a git checkout, and git is available, then git describe is used. Otherwise, the new checked in VERSION file is taken for the version. This mechanism uses a version.sh script inspired by http://git.musl-libc.org/cgit/musl/tree/tools/version.sh Signed-off-by: Michael Adam <obnox@samba.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 48ee0b2..1e71e35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,15 +3,7 @@
AC_PREREQ(2.54)
-m4_define([tinyproxy_major_version], [1])
-m4_define([tinyproxy_minor_version], [10])
-m4_define([tinyproxy_micro_version], [0])
-m4_define([tinyproxy_real_version],
- [tinyproxy_major_version.tinyproxy_minor_version.tinyproxy_micro_version])
-m4_define([tinyproxy_version], [tinyproxy_real_version])
-
-# For overriding the version string. Comment out if not needed.
-# m4_define([tinyproxy_version], [1.10.0])
+m4_define([tinyproxy_version], esyscmd(sh scripts/version.sh | tr -d '\n'))
AC_INIT([Tinyproxy], [tinyproxy_version],
[https://tinyproxy.github.io/],
@@ -227,6 +219,7 @@ docs/man8/tinyproxy.txt
m4macros/Makefile
tests/Makefile
tests/scripts/Makefile
+scripts/Makefile
])
AC_OUTPUT