summaryrefslogtreecommitdiffhomepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2018-09-04 01:23:01 +0200
committerMichael Adam <obnox@samba.org>2018-09-05 00:56:31 +0200
commit9f4ed46c0adf6ce6cb8dd44aff611448b64a37a7 (patch)
treee91782c1343270743cd5b8376855019d50f8a7b7 /Makefile.am
parenta662c11b8d106e0a2f3379b89739ed4770c5bbd3 (diff)
build: add new version mechanism based on VERSION file and a version.sh script
If this is a git checkout, and git is available, then git describe is used. Otherwise, the new checked in VERSION file is taken for the version. This mechanism uses a version.sh script inspired by http://git.musl-libc.org/cgit/musl/tree/tools/version.sh Signed-off-by: Michael Adam <obnox@samba.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e9113c2..4a3ead6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,8 @@ SUBDIRS = \
etc \
docs \
m4macros \
- tests
+ tests \
+ scripts
# tools want this on a single line
ACLOCAL_AMFLAGS = -I m4macros
@@ -20,7 +21,8 @@ dist_doc_DATA = \
EXTRA_DIST = \
autogen.sh \
tinyproxy-indent.sh \
- TODO
+ TODO \
+ VERSION
test: all
./tests/scripts/run_tests.sh