summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorYAMAMOTO Takashi <yamamoto@valinux.co.jp>2013-08-30 14:08:49 +0900
committerFUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>2013-09-02 14:41:27 +0900
commit205485e0520d8f37c49b66bbbf012a9448cd9367 (patch)
tree8fb682d3fc579d49244b761289118d13d1a7cf83 /setup.py
parent983aa398e963b4a2fefc41a2d26d8e3851295591 (diff)
stick with pbr 0.5.19
the latest versions of pbr generate scripts which don't support multiversion. to avoid importing modules from older multiversion-aware installations of ryu, we prefer multiversion-aware scripts. Signed-off-by: YAMAMOTO Takashi <yamamoto@valinux.co.jp> Signed-off-by: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 7 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index adf31fab..6df305e6 100644
--- a/setup.py
+++ b/setup.py
@@ -16,10 +16,14 @@
import setuptools
import os
-from ryu import version
-os.environ["PBR_VERSION"] = str(version)
+# the latest versions of pbr generate scripts which don't support
+# multiversion. to avoid importing modules from older multiversion-aware
+# installations of ryu, we prefer multiversion-aware scripts.
+PBR_VERSION = '0.5.19'
+
+os.environ["PBR_VERSION"] = PBR_VERSION
setuptools.setup(name='ryu',
- setup_requires=['pbr'],
+ setup_requires=['pbr==%s' % (PBR_VERSION,)],
pbr=True)