summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorYAMAMOTO Takashi <yamamoto@valinux.co.jp>2013-08-30 14:08:50 +0900
committerFUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>2013-09-02 14:41:28 +0900
commitada18bade1e593de9d0c14618609389af18cedb5 (patch)
tree26795b0616dfaec46a6e2b2de1df2f10015b8baa /setup.py
parent205485e0520d8f37c49b66bbbf012a9448cd9367 (diff)
workaround a python bug
without this patch, "python ./setup.py install" produced the following errors with python 2.7.3 on ubuntu 12.04. Error in sys.exitfunc: Traceback (most recent call last): File "/usr/lib/python2.7/atexit.py", line 24, in _run_exitfuncs func(*targs, **kargs) File "/usr/lib/python2.7/atexit.py", line 24, in _run_exitfuncs func(*targs, **kargs) File "/usr/lib/python2.7/multiprocessing/util.py", line 284, in _exit_function info('process shutting down') TypeError: 'NoneType' object is not callable Signed-off-by: YAMAMOTO Takashi <yamamoto@valinux.co.jp> Signed-off-by: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6df305e6..14553468 100644
--- a/setup.py
+++ b/setup.py
@@ -14,6 +14,12 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+# a bug workaround. http://bugs.python.org/issue15881
+try:
+ import multiprocessing
+except ImportError:
+ pass
+
import setuptools
import os