summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorFUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>2012-06-18 21:25:24 +0900
committerFUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>2012-06-19 11:20:07 +0900
commita364a7a7e23c2c6b0c9071899604e6d378f9a474 (patch)
tree66a3f1564655aceec9b9d5ee3ff20409d71b8235 /setup.py
parent8b93eda2cd38c3e7c44369ae1991894945089824 (diff)
Update setup.py
Use 'What's Ryu' section for RPM package description. Otherwise, we use README.rst for long_description so that we have a nice PyPI website. Signed-off-by: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 10 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e9a1088a..ef651249 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-# Copyright (C) 2011 Nippon Telegraph and Telephone Corporation.
+# Copyright (C) 2011, 2012 Nippon Telegraph and Telephone Corporation.
# Copyright (C) 2011 Isaku Yamahata <yamahata at valinux co jp>
#
# Licensed under the Apache License, Version 2.0 (the "License");
@@ -15,11 +15,19 @@
# limitations under the License.
import os
+import sys
from setuptools import find_packages
from setuptools import setup
-long_description = 'Ryu is an open-sourced network operating system licensed under Apache License v2. Ryu aims to provide logically centralized control and well defined API that makes it easy for cloud operators to implement network management applications on top of the Ryu. Currently, Ryu supports OpenFlow protocol to control the network devices.'
+doing_bdist = any(arg.startswith('bdist') for arg in sys.argv[1:])
+
+long_description = open('README.rst').read() + '\n\n'
+
+if doing_bdist:
+ start = long_description.find('=\n') + 2
+ long_description = long_description[
+ start:long_description.find('\n\n\n', start)]
classifiers = [
'License :: OSI Approved :: Apache Software License',