summaryrefslogtreecommitdiffhomepage
path: root/debian
diff options
context:
space:
mode:
authorYoshihiro Kaneko <ykaneko0929@gmail.com>2014-06-18 15:23:01 +0900
committerFUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>2014-06-19 08:41:51 +0900
commit03731ad04cab7746e095c44934fbdee3f1134ea0 (patch)
treea91194fbb592815448a26cf56a358a60b6d24877 /debian
parentcc6dcbabaa99c77e49fabf52445d2741fcaa7676 (diff)
package: add python-ryu-doc
This patch adds python-ryu-doc package which contains the HTML documentation generated from doc/. Also updates the man pages in doc/source/man/. Signed-off-by: Yoshihiro Kaneko <ykaneko0929@gmail.com> Signed-off-by: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/control17
-rw-r--r--debian/python-ryu-doc.doc-base9
-rw-r--r--debian/python-ryu-doc.docs2
-rwxr-xr-xdebian/rules19
-rw-r--r--debian/ryu-manager.8.txt124
-rw-r--r--debian/ryu.8.txt38
7 files changed, 43 insertions, 168 deletions
diff --git a/debian/changelog b/debian/changelog
index ec4c6267..bd1b6152 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,4 +2,4 @@ ryu (3.10-1) trusty; urgency=low
* Initial release.
- -- Ryu Project Team <ryu-devel@lists.sourceforge.net> Mon, 16 Jun 2014 15:21:36 +0900
+ -- Ryu Project Team <ryu-devel@lists.sourceforge.net> Wed, 18 Jun 2014 14:50:23 +0900
diff --git a/debian/control b/debian/control
index 11b312ad..c785be72 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: ryu
Section: net
Priority: optional
Maintainer: Ryu Project Team <ryu-devel@lists.sourceforge.net>
-Build-Depends: debhelper (>= 9.0.0), python-all (>= 2.6), txt2man
+Build-Depends: debhelper (>= 9.0.0), python-all (>= 2.6), python-sphinx
Build-Depends-Indep:
python-eventlet,
python-lxml,
@@ -37,6 +37,7 @@ Depends:
python-webob (>=1.0.8),
${misc:Depends},
${python:Depends}
+Suggests: python-ryu-doc
Provides: ${python:Provides}
XB-Python-Version: ${python:Versions}
Description: Ryu is a software defined networking framework
@@ -65,3 +66,17 @@ Description: Ryu is a software defined networking framework
Ryu supports fully 1.0, 1.2, 1.3, 1.4 and Nicira Extensions.
.
This package provides the Ryu manager.
+
+Package: python-ryu-doc
+Architecture: all
+Section: doc
+Description: Ryu is a software defined networking framework
+ Ryu is a component-based software defined networking framework.
+ Ryu provides software components with well defined API that make
+ it easy for developers to create new network management and control
+ applications. Ryu supports various protocols for managing network
+ devices, such as OpenFlow, Netconf, OF-config, etc. About OpenFlow,
+ Ryu supports fully 1.0, 1.2, 1.3, 1.4 and Nicira Extensions.
+ .
+ This package provides the HTML documentation including the Ryu API
+ manual.
diff --git a/debian/python-ryu-doc.doc-base b/debian/python-ryu-doc.doc-base
new file mode 100644
index 00000000..910f99d7
--- /dev/null
+++ b/debian/python-ryu-doc.doc-base
@@ -0,0 +1,9 @@
+Document: python-ryu-doc
+Title: Ryu User Documentation
+Author: Ryu Project Team
+Abstract: Ryu is a component-based software defined networking framework.
+Section: Programming/Python
+
+Format: HTML
+Index: /usr/share/doc/python-ryu-doc/html/index.html
+Files: /usr/share/doc/python-ryu-doc/html/*.html
diff --git a/debian/python-ryu-doc.docs b/debian/python-ryu-doc.docs
new file mode 100644
index 00000000..49a94fb4
--- /dev/null
+++ b/debian/python-ryu-doc.docs
@@ -0,0 +1,2 @@
+README.rst
+debian/html
diff --git a/debian/rules b/debian/rules
index fa1ae9f4..a854715e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,10 +11,18 @@ export DH_OPTIONS
%:
dh $@ --with python2
-override_dh_install:
- txt2man -d 'June 2014' -t ryu-manager -v "Ryu Manager's Manual" -s 8 < debian/ryu-manager.8.txt > debian/ryu-manager.8
- txt2man -d 'June 2014' -t ryu -v "Ryu Command's Manual" -s 8 < debian/ryu.8.txt > debian/ryu.8
- dh_install --fail-missing -X/usr/etc -X/usr/bin/quantum
+override_dh_installman:
+ cd doc; \
+ make man; \
+ cp build/man/* ../debian/
+ dh_installman
+
+override_dh_auto_build:
+ dh_auto_build
+ mkdir -p debian/html
+ cd doc; \
+ make html; \
+ cp -r build/html/* ../debian/html/
override_dh_installinit:
dh_installinit --no-start --name=ryu
@@ -22,3 +30,6 @@ override_dh_installinit:
override_dh_installlogrotate:
dh_installlogrotate --name=ryu
+override_dh_auto_clean:
+ rm -rf html
+ dh_auto_clean
diff --git a/debian/ryu-manager.8.txt b/debian/ryu-manager.8.txt
deleted file mode 100644
index c2270eb2..00000000
--- a/debian/ryu-manager.8.txt
+++ /dev/null
@@ -1,124 +0,0 @@
-NAME
- ryu-manager - management for Ryu application
-
-SYNOPSIS
- ryu-manager [-h]
- [--app-lists APP_LISTS] [--ca-certs CA_CERTS]
- [--config-dir DIR] [--config-file PATH]
- [--ctl-cert CTL_CERT] [--ctl-privkey CTL_PRIVKEY]
- [--default-log-level DEFAULT_LOG_LEVEL] [--explicit-drop]
- [--install-lldp-flow] [--log-config-file LOG_CONFIG_FILE]
- [--log-dir LOG_DIR] [--log-file LOG_FILE]
- [--log-file-mode LOG_FILE_MODE]
- [--neutron-admin-auth-url NEUTRON_ADMIN_AUTH_URL]
- [--neutron-admin-password NEUTRON_ADMIN_PASSWORD]
- [--neutron-admin-tenant-name NEUTRON_ADMIN_TENANT_NAME]
- [--neutron-admin-username NEUTRON_ADMIN_USERNAME]
- [--neutron-auth-strategy NEUTRON_AUTH_STRATEGY]
- [--neutron-controller-addr NEUTRON_CONTROLLER_ADDR]
- [--neutron-url NEUTRON_URL]
- [--neutron-url-timeout NEUTRON_URL_TIMEOUT]
- [--noexplicit-drop] [--noinstall-lldp-flow]
- [--noobserve-links] [--nouse-stderr] [--nouse-syslog]
- [--noverbose] [--observe-links]
- [--ofp-listen-host OFP_LISTEN_HOST]
- [--ofp-ssl-listen-port OFP_SSL_LISTEN_PORT]
- [--ofp-tcp-listen-port OFP_TCP_LISTEN_PORT] [--use-stderr]
- [--use-syslog] [--verbose] [--version]
- [--wsapi-host WSAPI_HOST] [--wsapi-port WSAPI_PORT]
- [--test-switch-dir TEST-SWITCH_DIR]
- [--test-switch-target TEST-SWITCH_TARGET]
- [--test-switch-tester TEST-SWITCH_TESTER]
- [app [app ...]]
-
-DESCRIPTION
- ryu-manager is the executable for Ryu applications. ryu-manager loads
- Ryu applications and run it.
-
- Ryu is a component-based software defined networking framework. Ryu
- provides software components with well defined API that make it easy for
- developers to create new network management and control applications.
- Ryu supports various protocols for managing network devices, such as
- OpenFlow, Netconf, OF-config, etc. About OpenFlow, Ryu supports fully
- 1.0, 1.2, 1.3, 1.4 and Nicira Extensions.
-
-OPTIONS
- app application module name to run
-
- -h, --help show this help message and exit
- --app-lists APP_LISTS
- application module name to run
- --ca-certs CA_CERTS CA certificates
- --config-dir DIR Path to a config directory to pull *.conf files from.
- This file set is sorted, so as to provide a
- predictable parse order if individual options are
- over-ridden. The set is parsed after the file(s)
- specified via previous --config-file, arguments hence
- over-ridden options in the directory take precedence.
- --config-file PATH Path to a config file to use. Multiple config files
- can be specified, with values in later files taking
- precedence. The default files used are: None
- --ctl-cert CTL_CERT controller certificate
- --ctl-privkey CTL_PRIVKEY
- controller private key
- --default-log-level DEFAULT_LOG_LEVEL
- default log level
- --explicit-drop link discovery: explicitly drop lldp packet in
- --install-lldp-flow link discovery: explicitly install flow entry to send
- lldp packet to controller
- --log-config-file LOG_CONFIG_FILE
- Path to a logging config file to use
- --log-dir LOG_DIR log file directory
- --log-file LOG_FILE log file name
- --log-file-mode LOG_FILE_MODE
- default log file permission
- --neutron-admin-auth-url NEUTRON_ADMIN_AUTH_URL
- auth url for connecting to neutron in admin context
- --neutron-admin-password NEUTRON_ADMIN_PASSWORD
- password for connecting to neutron in admin context
- --neutron-admin-tenant-name NEUTRON_ADMIN_TENANT_NAME
- tenant name for connecting to neutron in admin context
- --neutron-admin-username NEUTRON_ADMIN_USERNAME
- username for connecting to neutron in admin context
- --neutron-auth-strategy NEUTRON_AUTH_STRATEGY
- auth strategy for connecting to neutron in
- admincontext
- --neutron-controller-addr NEUTRON_CONTROLLER_ADDR
- openflow method:address:port to set controller ofovs
- bridge
- --neutron-url NEUTRON_URL
- URL for connecting to neutron
- --neutron-url-timeout NEUTRON_URL_TIMEOUT
- timeout value for connecting to neutron in seconds
- --noexplicit-drop The inverse of --explicit-drop
- --noinstall-lldp-flow
- The inverse of --install-lldp-flow
- --noobserve-links The inverse of --observe-links
- --nouse-stderr The inverse of --use-stderr
- --nouse-syslog The inverse of --use-syslog
- --noverbose The inverse of --verbose
- --observe-links observe link discovery events.
- --ofp-listen-host OFP_LISTEN_HOST
- openflow listen host
- --ofp-ssl-listen-port OFP_SSL_LISTEN_PORT
- openflow ssl listen port
- --ofp-tcp-listen-port OFP_TCP_LISTEN_PORT
- openflow tcp listen port
- --use-stderr log to standard error
- --use-syslog output to syslog
- --verbose show debug output
- --version show program's version number and exit
- --wsapi-host WSAPI_HOST
- webapp listen host
- --wsapi-port WSAPI_PORT
- webapp listen port
-
- --test-switch-dir TEST-SWITCH_DIR
- test files directory
- --test-switch-target TEST-SWITCH_TARGET
- target sw dp-id
- --test-switch-tester TEST-SWITCH_TESTER
- tester sw dp-id
-
-AUTHOR
- Ryu Project Team <ryu-devel@lists.sourceforge.net>
diff --git a/debian/ryu.8.txt b/debian/ryu.8.txt
deleted file mode 100644
index 11855d72..00000000
--- a/debian/ryu.8.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-NAME
- ryu - management for Ryu application
-
-SYNOPSIS
- ryu [-h] [--config-dir DIR] [--config-file PATH] [--version]
- [subcommand] ...
-
-DESCRIPTION
- ryu is the executable for Ryu applications. ryu loads a sub-module
- corresponding to the sub-command and run it. 'run' sub-command is an
- equivalent to ryu-manager.
-
- Ryu is a component-based software defined networking framework. Ryu
- provides software components with well defined API that make it easy for
- developers to create new network management and control applications.
- Ryu supports various protocols for managing network devices, such as
- OpenFlow, Netconf, OF-config, etc. About OpenFlow, Ryu supports fully
- 1.0, 1.2, 1.3, 1.4 and Nicira Extensions.
-
-
-OPTIONS
- subcommand [rpc-cli|run|of-config-cli]
- subcommand_args subcommand specific arguments
-
- -h, --help show this help message and exit
- --config-dir DIR Path to a config directory to pull *.conf files from.
- This file set is sorted, so as to provide a predictable
- parse order if individual options are over-ridden. The
- set is parsed after the file(s) specified via previous
- --config-file, arguments hence over-ridden options in
- the directory take precedence.
- --config-file PATH Path to a config file to use. Multiple config files can
- be specified, with values in later files taking
- precedence. The default files used are: None
- --version show program's version number and exit
-
-AUTHOR
- Ryu Project Team <ryu-devel@lists.sourceforge.net>