summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 8 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 04286b15..4a858326 100644
--- a/setup.py
+++ b/setup.py
@@ -40,9 +40,10 @@ import sys
try:
from setuptools import setup
kw = {
- 'install_requires': ['pycrypto >= 2.1, != 2.4',
- 'ecdsa',
- ],
+ 'install_requires': [
+ 'pycrypto >= 2.1, != 2.4',
+ 'ecdsa',
+ ],
}
except ImportError:
from distutils.core import setup
@@ -55,7 +56,7 @@ if sys.platform == 'darwin':
setup(
name = "paramiko",
- version = "1.12.4",
+ version = "1.13.0",
description = "SSH2 protocol library",
long_description = longdesc,
author = "Jeff Forcier",
@@ -73,10 +74,11 @@ setup(
'Topic :: Security :: Cryptography',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.5',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 2 :: Only',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
],
**kw
)