summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 7 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index f9c4b4fe..ad957329 100644
--- a/setup.py
+++ b/setup.py
@@ -31,23 +31,10 @@ To install the `in-development version
`pip install paramiko==dev`.
'''
-# if someday we want to *require* setuptools, uncomment this:
-# (it will cause setuptools to be automatically downloaded)
-#import ez_setup
-#ez_setup.use_setuptools()
-
import sys
-try:
- from setuptools import setup
- kw = {
- 'install_requires': [
- 'pycrypto>=2.1,!=2.4',
- 'ecdsa>=0.11',
- ],
- }
-except ImportError:
- from distutils.core import setup
- kw = {}
+
+from setuptools import setup
+
if sys.platform == 'darwin':
import setup_helper
@@ -89,5 +76,8 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
],
- **kw
+ install_requires=[
+ 'pycrypto>=2.1,!=2.4',
+ 'ecdsa>=0.11',
+ ],
)