diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 3 insertions, 4 deletions
@@ -24,14 +24,13 @@ connections between python scripts. All major ciphers and hash methods are supported. SFTP client and server mode are both supported too. Required packages: - pyCrypto + Cryptography To install the development version, ``pip install -e git+https://github.com/paramiko/paramiko/#egg=paramiko``. ''' import sys - from setuptools import setup @@ -76,7 +75,7 @@ setup( 'Programming Language :: Python :: 3.5', ], install_requires=[ - 'pycrypto>=2.1,!=2.4,<3.0', - 'ecdsa>=0.11,<2.0', + 'cryptography>=1.1', + 'pyasn1>=0.1.7', ], ) |