summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 9 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 64b3401f..9eb1c9d0 100644
--- a/setup.py
+++ b/setup.py
@@ -1,23 +1,25 @@
from distutils.core import setup
longdesc = '''
-This is a library for making client-side SSH2 connections (server-side is
-coming soon). All major ciphers and hash methods are supported.
+This is a library for making SSH2 connections (client or server).
+Emphasis is on using SSH2 as an alternative to SSL for making secure
+connections between pyton scripts. All major ciphers and hash methods
+are supported.
Required packages:
pyCrypto
'''
setup(name = "secsh",
- version = "0.1-bulbasaur",
+ version = "0.1-charmander",
description = "SSH2 protocol library",
author = "Robey Pointer",
author_email = "robey@lag.net",
url = "http://www.lag.net/~robey/secsh/",
- py_modules = [ 'secsh', 'transport', 'channel', 'message', 'util', 'ber',
- 'kex_group1', 'kex_gex', 'rsakey', 'dsskey' ],
- scripts = [ 'demo.py' ],
- download_url = 'http://www.lag.net/~robey/secsh/secsh-0.1-bulbasaur.zip',
+ py_modules = [ 'secsh', 'transport', 'auth_transport', 'channel',
+ 'message', 'util', 'ber', 'kex_group1', 'kex_gex',
+ 'rsakey', 'dsskey' ],
+ download_url = 'http://www.lag.net/~robey/secsh/secsh-0.1-charmander.zip',
license = 'LGPL',
platforms = 'Posix; MacOS X; Windows',
classifiers = [ 'Development Status :: 3 - Alpha',