summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 003a0617..91e9640c 100644
--- a/setup.py
+++ b/setup.py
@@ -24,7 +24,7 @@ connections between python scripts. All major ciphers and hash methods
are supported. SFTP client and server mode are both supported too.
Required packages:
- pyCrypto
+ Cryptography
To install the `in-development version
<https://github.com/paramiko/paramiko/tarball/master#egg=paramiko-dev>`_, use
@@ -41,8 +41,9 @@ try:
from setuptools import setup
kw = {
'install_requires': [
- 'pycrypto >= 2.1, != 2.4',
+ 'cryptography >= 0.5.4',
'ecdsa >= 0.11',
+ 'pyasn1',
],
}
except ImportError: