diff options
author | Alex Gaynor <alex.gaynor@gmail.com> | 2016-04-25 20:27:32 -0400 |
---|---|---|
committer | Alex Gaynor <alex.gaynor@gmail.com> | 2016-04-25 20:27:32 -0400 |
commit | 79fcbdad812cc3be39afbf8375c11e0581eeb86e (patch) | |
tree | a291236fc63b525a78ff52cd7b4a87c10f30c0d9 /setup.py | |
parent | b4474bb60e8a081968efbfe7de2e5869522455e1 (diff) | |
parent | 86645149c9d066d5fe9222525c8bdf91df7f7de9 (diff) |
Merge branch 'master' into remove-rc4
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 25 |
1 files changed, 7 insertions, 18 deletions
@@ -24,30 +24,16 @@ connections between python scripts. All major ciphers and hash methods are supported. SFTP client and server mode are both supported too. Required packages: - pyCrypto + Cryptography To install the `in-development version <https://github.com/paramiko/paramiko/tarball/master#egg=paramiko-dev>`_, use `pip install paramiko==dev`. ''' -# if someday we want to *require* setuptools, uncomment this: -# (it will cause setuptools to be automatically downloaded) -#import ez_setup -#ez_setup.use_setuptools() - import sys -try: - from setuptools import setup - kw = { - 'install_requires': [ - 'pycrypto>=2.1,!=2.4', - 'ecdsa>=0.11', - ], - } -except ImportError: - from distutils.core import setup - kw = {} +from setuptools import setup + if sys.platform == 'darwin': import setup_helper @@ -89,5 +75,8 @@ setup( 'Programming Language :: Python :: 3.4', 'Programming Language :: Python :: 3.5', ], - **kw + install_requires=[ + 'cryptography>=0.8', + 'pyasn1>=0.1.7', + ], ) |