diff options
author | Alex Gaynor <alex.gaynor@gmail.com> | 2016-04-23 13:53:07 -0400 |
---|---|---|
committer | Jeff Forcier <jeff@bitprophet.org> | 2016-04-24 19:01:42 -0700 |
commit | 76a14eddc6796c264d45d8069c8f02345a855624 (patch) | |
tree | 346769a5673967f7e690646c04ea75da05f845e8 /setup.py | |
parent | 634032fbdcc877b26b34a5a4ea26c05340f93b1d (diff) |
Simplify setup.py by always relying on setuptools
It is installed everywhere now, there is no practical way to use python without it.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 24 |
1 files changed, 7 insertions, 17 deletions
@@ -31,23 +31,10 @@ To install the `in-development version `pip install paramiko==dev`. ''' -# if someday we want to *require* setuptools, uncomment this: -# (it will cause setuptools to be automatically downloaded) -#import ez_setup -#ez_setup.use_setuptools() - import sys -try: - from setuptools import setup - kw = { - 'install_requires': [ - 'pycrypto>=2.1,!=2.4', - 'ecdsa>=0.11', - ], - } -except ImportError: - from distutils.core import setup - kw = {} + +from setuptools import setup + if sys.platform == 'darwin': import setup_helper @@ -89,5 +76,8 @@ setup( 'Programming Language :: Python :: 3.4', 'Programming Language :: Python :: 3.5', ], - **kw + install_requires=[ + 'pycrypto>=2.1,!=2.4', + 'ecdsa>=0.11', + ], ) |