diff options
author | Jeff Forcier <jeff@bitprophet.org> | 2014-09-08 15:01:18 -0700 |
---|---|---|
committer | Jeff Forcier <jeff@bitprophet.org> | 2014-09-08 15:03:12 -0700 |
commit | 68f7dbea29bb700caf5885ffe8af6bc7bd5ad92b (patch) | |
tree | 3fbee6b5c76ca2a38cb3abf527f6643a3cd6957c /setup.py | |
parent | 021160d8db62b8873f7deda3f7d89750941d2704 (diff) | |
parent | 88d932f2bbab907879639122969fb1f763258d29 (diff) |
Merge branch 'master' into 362-int
Conflicts:
tests/test_client.py
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 12 |
1 files changed, 10 insertions, 2 deletions
@@ -42,7 +42,7 @@ try: kw = { 'install_requires': [ 'pycrypto >= 2.1, != 2.4', - 'ecdsa', + 'ecdsa >= 0.11', ], } except ImportError: @@ -54,9 +54,16 @@ if sys.platform == 'darwin': setup_helper.install_custom_make_tarball() +# Version info -- read without importing +_locals = {} +with open('paramiko/_version.py') as fp: + exec(fp.read(), None, _locals) +version = _locals['__version__'] + + setup( name = "paramiko", - version = "1.14.0", + version = version, description = "SSH2 protocol library", long_description = longdesc, author = "Jeff Forcier", @@ -79,6 +86,7 @@ setup( 'Programming Language :: Python :: 3', 'Programming Language :: Python :: 3.2', 'Programming Language :: Python :: 3.3', + 'Programming Language :: Python :: 3.4', ], **kw ) |