diff options
author | Robey Pointer <robey@lag.net> | 2003-12-30 07:18:20 +0000 |
---|---|---|
committer | Robey Pointer <robey@lag.net> | 2003-12-30 07:18:20 +0000 |
commit | 48c7d888a22a6810a32f6d25cdd6b561803166cd (patch) | |
tree | 33e22ab7a6f56ef6b569c674817127bb1108f7dd /setup.py | |
parent | 36d6d95dc6db1f47d187b87ab1c1a10c1d30558f (diff) |
[project @ Arch-1:robey@lag.net--2003-public%secsh--dev--1.0--patch-17]
lots more documentation, and added Transport.connect()
renamed demo_host_key to demo_rsa_key. moved changelog to a separate file,
and indicated that future changelog entries should be fetched from tla.
tried to clean up "__all__" in a way that makes epydoc still work.
added lots more documentation, and renamed many methods and vars to hide
them as private non-exported API.
Transport's ModulusPack is now a static member, so it only has to be loaded
once, and can then be used by any future Transport object.
added Transport.connect(), which tries to wrap all the SSH2 negotiation and
authentication into one method. you should be able to create a Transport,
call connect(), and then create channels.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -3,7 +3,7 @@ from distutils.core import setup longdesc = ''' This is a library for making SSH2 connections (client or server). Emphasis is on using SSH2 as an alternative to SSL for making secure -connections between pyton scripts. All major ciphers and hash methods +connections between python scripts. All major ciphers and hash methods are supported. (Previous name: secsh) |