summaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorJeff Forcier <jeff@bitprophet.org>2017-06-06 12:31:57 -0700
committerJeff Forcier <jeff@bitprophet.org>2017-06-06 12:31:57 -0700
commita2da21d46bb9a441dbb8da570262bb424e1f9450 (patch)
tree8e1c7bdd402fb640f75b061bc2051f5fe6eba676 /setup.py
parent79fcbdad812cc3be39afbf8375c11e0581eeb86e (diff)
parentd285b80ecb6102b0ad501b74d02e04d61e8ec632 (diff)
Merge branch '2.0' into 667-int
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py48
1 files changed, 23 insertions, 25 deletions
diff --git a/setup.py b/setup.py
index 4f370d63..80d5ea7f 100644
--- a/setup.py
+++ b/setup.py
@@ -16,6 +16,13 @@
# along with Paramiko; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Suite 500, Boston, MA 02110-1335 USA.
+import sys
+from setuptools import setup
+
+if sys.platform == 'darwin':
+ import setup_helper
+
+ setup_helper.install_custom_make_tarball()
longdesc = '''
This is a library for making SSH2 connections (client or server).
@@ -26,19 +33,10 @@ are supported. SFTP client and server mode are both supported too.
Required packages:
Cryptography
-To install the `in-development version
-<https://github.com/paramiko/paramiko/tarball/master#egg=paramiko-dev>`_, use
-`pip install paramiko==dev`.
+To install the development version, ``pip install -e
+git+https://github.com/paramiko/paramiko/#egg=paramiko``.
'''
-import sys
-from setuptools import setup
-
-
-if sys.platform == 'darwin':
- import setup_helper
- setup_helper.install_custom_make_tarball()
-
# Version info -- read without importing
_locals = {}
@@ -46,22 +44,22 @@ with open('paramiko/_version.py') as fp:
exec(fp.read(), None, _locals)
version = _locals['__version__']
-
setup(
- name = "paramiko",
- version = version,
- description = "SSH2 protocol library",
- long_description = longdesc,
- author = "Jeff Forcier",
- author_email = "jeff@bitprophet.org",
- url = "https://github.com/paramiko/paramiko/",
- packages = [ 'paramiko' ],
- license = 'LGPL',
- platforms = 'Posix; MacOS X; Windows',
- classifiers = [
+ name="paramiko",
+ version=version,
+ description="SSH2 protocol library",
+ long_description=longdesc,
+ author="Jeff Forcier",
+ author_email="jeff@bitprophet.org",
+ url="https://github.com/paramiko/paramiko/",
+ packages=['paramiko'],
+ license='LGPL',
+ platforms='Posix; MacOS X; Windows',
+ classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
- 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)',
+ 'License :: OSI Approved :: '
+ 'GNU Library or Lesser General Public License (LGPL)',
'Operating System :: OS Independent',
'Topic :: Internet',
'Topic :: Security :: Cryptography',
@@ -76,7 +74,7 @@ setup(
'Programming Language :: Python :: 3.5',
],
install_requires=[
- 'cryptography>=0.8',
+ 'cryptography>=1.1',
'pyasn1>=0.1.7',
],
)