diff options
author | Alex Gaynor <alex.gaynor@gmail.com> | 2016-04-24 22:08:40 -0400 |
---|---|---|
committer | Alex Gaynor <alex.gaynor@gmail.com> | 2016-04-24 22:08:40 -0400 |
commit | 900b42620a15739f36b6de73bfa277d10b182a3b (patch) | |
tree | 2f47b9998e66c2675e7f1a0f7ceb069b50a703c1 /setup.py | |
parent | d1e43c151f7cabf2738de432c6bc9d011bc3a85d (diff) | |
parent | 1cda0eb75cd5e1f7da383e52df349ae8419349e8 (diff) |
Merge branch 'master' into switch-to-cryptography
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 24 |
1 files changed, 7 insertions, 17 deletions
@@ -31,23 +31,10 @@ To install the `in-development version `pip install paramiko==dev`. ''' -# if someday we want to *require* setuptools, uncomment this: -# (it will cause setuptools to be automatically downloaded) -#import ez_setup -#ez_setup.use_setuptools() - import sys -try: - from setuptools import setup - kw = { - 'install_requires': [ - 'cryptography>=0.8', - 'pyasn1>=0.1.7', - ], - } -except ImportError: - from distutils.core import setup - kw = {} + +from setuptools import setup + if sys.platform == 'darwin': import setup_helper @@ -89,5 +76,8 @@ setup( 'Programming Language :: Python :: 3.4', 'Programming Language :: Python :: 3.5', ], - **kw + install_requires=[ + 'cryptography>=0.8', + 'pyasn1>=0.1.7', + ], ) |