diff options
author | Kieran Spear <kispear@gmail.com> | 2014-03-31 12:01:32 +1100 |
---|---|---|
committer | Kieran Spear <kispear@gmail.com> | 2014-03-31 12:59:02 +1100 |
commit | 77b1aaccc6dcc17108da17dc609c81bdd4e9a0e5 (patch) | |
tree | 25bf49ea5f105abe1943648ad43a1df32c498694 /setup.py | |
parent | 5a430def22aa5cbd755f347c8714e4140d6cdcab (diff) |
Don't validate points in known_hosts ECDSA keys
Point validation is really expensive and apparently unnecessary when
we already trust the keys in our known_hosts file.
With my current known_hosts file of 657 keys, this reduces the time
taken to complete a remote task in fabric from 24 seconds to 7 seconds.
This requires python-ecdsa >= 0.11.
Closes #270.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -41,7 +41,7 @@ try: from setuptools import setup kw = { 'install_requires': ['pycrypto >= 2.1, != 2.4', - 'ecdsa', + 'ecdsa >= 0.11', ], } except ImportError: |