summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-18 16:07:04 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-18 17:08:21 +0100
commitd9ac7320c80a4629d678fbd905defa831094434c (patch)
tree69e25b9fc73b90b38a0389e32fdebdd7a45907e5 /CMakeLists.txt
parentbf0948ef5ee92ace7f8f46ab7cf71ddec09a90a1 (diff)
Build with largefile support
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ec45c52..8c285dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,7 @@ PROJECT(uhttpd C)
INCLUDE (CheckFunctionExists)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
-ADD_DEFINITIONS(-Os -Wall -Werror -Wmissing-declarations --std=gnu99 -g3)
+ADD_DEFINITIONS(-D_FILE_OFFSET_BITS=64 -Os -Wall -Werror -Wmissing-declarations --std=gnu99 -g3)
OPTION(TLS_SUPPORT "TLS support" ON)
OPTION(LUA_SUPPORT "Lua support" ON)