summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-12-30 19:36:18 +0100
committerFelix Fietkau <nbd@openwrt.org>2012-12-30 19:36:18 +0100
commit30fff08a44094df9b775f2e4bf9f5abceb847415 (patch)
treea89070cb95860a117a4a079bfed9202ecdfcd870 /CMakeLists.txt
Initial implementation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..3489414
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(uhttpd C)
+ADD_DEFINITIONS(-O1 -Wall -Werror --std=gnu99 -g3)
+
+IF(APPLE)
+ INCLUDE_DIRECTORIES(/opt/local/include)
+ LINK_DIRECTORIES(/opt/local/lib)
+ENDIF()
+
+ADD_EXECUTABLE(uhttpd main.c listen.c client.c utils.c file.c)
+TARGET_LINK_LIBRARIES(uhttpd ubox ubus)