summaryrefslogtreecommitdiffhomepage
path: root/protocols
diff options
context:
space:
mode:
Diffstat (limited to 'protocols')
-rw-r--r--protocols/luci-proto-wireguard/Makefile2
-rw-r--r--protocols/luci-proto-wireguard/htdocs/luci-static/resources/protocol/wireguard.js93
-rwxr-xr-xprotocols/luci-proto-wireguard/root/usr/libexec/rpcd/luci.wireguard26
-rw-r--r--protocols/luci-proto-wireguard/root/usr/share/rpcd/acl.d/luci-wireguard.json5
4 files changed, 98 insertions, 28 deletions
diff --git a/protocols/luci-proto-wireguard/Makefile b/protocols/luci-proto-wireguard/Makefile
index f88b90bbfa..45ec1921cc 100644
--- a/protocols/luci-proto-wireguard/Makefile
+++ b/protocols/luci-proto-wireguard/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=Support for WireGuard VPN
-LUCI_DEPENDS:=+wireguard-tools
+LUCI_DEPENDS:=+wireguard-tools +luci-app-wireguard
LUCI_PKGARCH:=all
include ../../luci.mk
diff --git a/protocols/luci-proto-wireguard/htdocs/luci-static/resources/protocol/wireguard.js b/protocols/luci-proto-wireguard/htdocs/luci-static/resources/protocol/wireguard.js
index e7e69a3d5b..51f9accf46 100644
--- a/protocols/luci-proto-wireguard/htdocs/luci-static/resources/protocol/wireguard.js
+++ b/protocols/luci-proto-wireguard/htdocs/luci-static/resources/protocol/wireguard.js
@@ -11,6 +11,13 @@ var generateKey = rpc.declare({
expect: { keys: {} }
});
+var generateQrCode = rpc.declare({
+ object: 'luci.wireguard',
+ method: 'generateQrCode',
+ params: ['privkey', 'psk', 'allowed_ips'],
+ expect: { qr_code: '' }
+});
+
function validateBase64(section_id, value) {
if (value.length == 0)
return true;
@@ -24,6 +31,24 @@ function validateBase64(section_id, value) {
return true;
}
+function findSection(sections, name) {
+ for (var i = 0; i < sections.length; i++) {
+ var section = sections[i];
+ if (section['.name'] == name) return section;
+ }
+
+ return null;
+}
+
+function generateDescription(name, texts) {
+ return E('li', { 'style': 'color: inherit;' }, [
+ E('span', name),
+ E('ul', texts.map(function (text) {
+ return E('li', { 'style': 'color: inherit;' }, text);
+ }))
+ ]);
+}
+
return network.registerProtocol('wireguard', {
getI18n: function() {
return _('WireGuard VPN');
@@ -131,6 +156,74 @@ return network.registerProtocol('wireguard', {
o.datatype = 'string';
o.optional = true;
+ o = ss.option(form.Value, 'description', _('QR-Code'));
+ o.render = L.bind(function (view, section_id) {
+ var sections = uci.sections('network');
+ var client = findSection(sections, section_id);
+ var serverName = this.getIfname();
+ var server = findSection(sections, serverName);
+
+ var interfaceTexts = [
+ 'PrivateKey: ' + _('A random, on the fly generated "PrivateKey", the key will not be saved on the router')
+ ];
+
+ var peerTexts = [
+ 'PublicKey: ' + _('The "PublicKey" of that wg interface'),
+ 'AllowedIPs: ' + _('The list of this client\'s "AllowedIPs" or "0.0.0.0/0, ::/0" if not configured'),
+ 'PresharedKey: ' + _('If available, the client\'s "PresharedKey"')
+ ];
+
+ var description = [
+ E('span', '%q<br>%q'.format(_('If there are any unsaved changes for this client, please save the configuration before generating a QR-Code'),
+ _('The QR-Code works per wg interface, it will be refreshed with every button click and transfers the following information:'))),
+ E('ul', [
+ generateDescription('[Interface]', interfaceTexts),
+ generateDescription('[Peer]', peerTexts)
+ ])
+ ];
+
+ return E('div', { 'class': 'cbi-value' }, [
+ E('label', { 'class': 'cbi-value-title' }, _('QR-Code')),
+ E('div', {
+ 'style': 'display: flex; flex-direction: column; align-items: baseline;',
+ 'id': 'qr-' + section_id
+ }, [
+ E('button', {
+ 'class': 'btn cbi-button cbi-button-apply',
+ 'click': ui.createHandlerFn(this, function (server, client, section_id) {
+ var qrDiv = document.getElementById('qr-' + section_id);
+ var qrEl = qrDiv.querySelector('value');
+ var qrBtn = qrDiv.querySelector('button');
+ var qrencodeErr = '<b>%q</b>'.format(
+ _('For QR-Code support please install the qrencode package!'));
+
+ if (qrEl.innerHTML != '' && qrEl.innerHTML != qrencodeErr) {
+ qrEl.innerHTML = '';
+ qrBtn.innerHTML = _('Generate New QR-Code')
+ } else {
+ qrEl.innerHTML = _('Loading QR-Code...');
+
+ generateQrCode(server.private_key, client.preshared_key,
+ client.allowed_ips).then(function (qrCode) {
+ if (qrCode == '') {
+ qrEl.innerHTML = qrencodeErr;
+ } else {
+ qrEl.innerHTML = qrCode;
+ qrBtn.innerHTML = _('Hide QR-Code');
+ }
+ });
+ }
+ }, server, client, section_id)
+ }, _('Generate new QR-Code')),
+ E('value', {
+ 'class': 'cbi-section',
+ 'style': 'margin: 0;'
+ }),
+ E('div', { 'class': 'cbi-value-description' }, description)
+ ])
+ ]);
+ }, this);
+
o = ss.option(form.Value, 'public_key', _('Public Key'), _('Required. Base64-encoded public key of peer.'));
o.validate = validateBase64;
o.rmempty = false;
diff --git a/protocols/luci-proto-wireguard/root/usr/libexec/rpcd/luci.wireguard b/protocols/luci-proto-wireguard/root/usr/libexec/rpcd/luci.wireguard
deleted file mode 100755
index a6c951f3de..0000000000
--- a/protocols/luci-proto-wireguard/root/usr/libexec/rpcd/luci.wireguard
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-
-. /usr/share/libubox/jshn.sh
-
-case "$1" in
- list)
- json_init
- json_add_object "generateKeyPair"
- json_close_object
- json_dump
- ;;
- call)
- case "$2" in
- generateKeyPair)
- prv=$(wg genkey)
- pub=$(echo $prv | wg pubkey)
- json_init
- json_add_object "keys"
- json_add_string "priv" "$prv"
- json_add_string "pub" "$pub"
- json_close_object
- json_dump
- ;;
- esac
- ;;
-esac
diff --git a/protocols/luci-proto-wireguard/root/usr/share/rpcd/acl.d/luci-wireguard.json b/protocols/luci-proto-wireguard/root/usr/share/rpcd/acl.d/luci-wireguard.json
index 4bbcb81578..04877d4f49 100644
--- a/protocols/luci-proto-wireguard/root/usr/share/rpcd/acl.d/luci-wireguard.json
+++ b/protocols/luci-proto-wireguard/root/usr/share/rpcd/acl.d/luci-wireguard.json
@@ -3,7 +3,10 @@
"description": "Grant access to LuCI Wireguard procedures",
"write": {
"ubus": {
- "luci.wireguard": [ "generateKeyPair" ]
+ "luci.wireguard": [
+ "generateKeyPair",
+ "generateQrCode"
+ ]
}
}
}