summaryrefslogtreecommitdiffhomepage
path: root/protocols
diff options
context:
space:
mode:
Diffstat (limited to 'protocols')
-rw-r--r--protocols/luci-proto-autoip/Makefile14
-rw-r--r--protocols/luci-proto-autoip/htdocs/luci-static/resources/protocol/autoip.js16
2 files changed, 30 insertions, 0 deletions
diff --git a/protocols/luci-proto-autoip/Makefile b/protocols/luci-proto-autoip/Makefile
new file mode 100644
index 0000000000..1a8181a3e5
--- /dev/null
+++ b/protocols/luci-proto-autoip/Makefile
@@ -0,0 +1,14 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=Support for Avahi IPv4LL configuration
+LUCI_DEPENDS:=+avahi-autoipd
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/protocols/luci-proto-autoip/htdocs/luci-static/resources/protocol/autoip.js b/protocols/luci-proto-autoip/htdocs/luci-static/resources/protocol/autoip.js
new file mode 100644
index 0000000000..5c8ead45d6
--- /dev/null
+++ b/protocols/luci-proto-autoip/htdocs/luci-static/resources/protocol/autoip.js
@@ -0,0 +1,16 @@
+'use strict';
+'require network';
+
+return network.registerProtocol('autoip', {
+ getI18n: function() {
+ return _('Avahi IPv4LL');
+ },
+
+ getOpkgPackage: function() {
+ return 'avahi-autoipd';
+ },
+
+ renderFormOptions: function(s) {
+
+ }
+});