summaryrefslogtreecommitdiffhomepage
path: root/protocols
diff options
context:
space:
mode:
Diffstat (limited to 'protocols')
-rw-r--r--protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua2
-rw-r--r--protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_map.lua2
-rw-r--r--protocols/luci-proto-openconnect/luasrc/model/cbi/admin_network/proto_openconnect.lua2
-rw-r--r--protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_l2tp.lua2
-rw-r--r--protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pppossh.lua122
-rw-r--r--protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pptp.lua2
-rw-r--r--protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua8
-rw-r--r--protocols/luci-proto-vpnc/Makefile23
-rw-r--r--protocols/luci-proto-vpnc/luasrc/model/cbi/admin_network/proto_vpnc.lua82
-rw-r--r--protocols/luci-proto-vpnc/luasrc/model/network/proto_vpnc.lua46
10 files changed, 285 insertions, 6 deletions
diff --git a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua
index 9315dc25bf..7b5e6043cc 100644
--- a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua
+++ b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua
@@ -39,7 +39,7 @@ protocol.optional = true
server = section:taboption("general", Value, "server",
translate("Tunnel setup server"),
translate("Optional, specify to override default server (tic.sixxs.net)"))
-server.datatype = "host"
+server.datatype = "host(0)"
server.optional = true
diff --git a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_map.lua b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_map.lua
index 2f8108ef1c..37d4ec901a 100644
--- a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_map.lua
+++ b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_map.lua
@@ -50,7 +50,7 @@ ip6prefixlen.datatype = "range(0,64)"
s:taboption("general", Value, "ealen",
- translate("EA-bits length")).datatype = "range(0,16)"
+ translate("EA-bits length")).datatype = "range(0,48)"
s:taboption("general", Value, "psidlen",
translate("PSID-bits length")).datatype = "range(0,16)"
diff --git a/protocols/luci-proto-openconnect/luasrc/model/cbi/admin_network/proto_openconnect.lua b/protocols/luci-proto-openconnect/luasrc/model/cbi/admin_network/proto_openconnect.lua
index 4ed34ae3bc..ad3f2edf0b 100644
--- a/protocols/luci-proto-openconnect/luasrc/model/cbi/admin_network/proto_openconnect.lua
+++ b/protocols/luci-proto-openconnect/luasrc/model/cbi/admin_network/proto_openconnect.lua
@@ -13,7 +13,7 @@ oc_key_file = "/etc/openconnect/user-key-" .. ifc .. ".pem"
oc_ca_file = "/etc/openconnect/ca-" .. ifc .. ".pem"
server = section:taboption("general", Value, "server", translate("VPN Server"))
-server.datatype = "host"
+server.datatype = "host(0)"
port = section:taboption("general", Value, "port", translate("VPN Server port"))
port.placeholder = "443"
diff --git a/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_l2tp.lua b/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_l2tp.lua
index 523ef1bc6f..506170c2de 100644
--- a/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_l2tp.lua
+++ b/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_l2tp.lua
@@ -8,7 +8,7 @@ local ipv6, defaultroute, metric, peerdns, dns, mtu
server = section:taboption("general", Value, "server", translate("L2TP Server"))
-server.datatype = "host"
+server.datatype = "or(host(1), hostport(1))"
username = section:taboption("general", Value, "username", translate("PAP/CHAP username"))
diff --git a/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pppossh.lua b/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pppossh.lua
new file mode 100644
index 0000000000..eca7bdd4d3
--- /dev/null
+++ b/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pppossh.lua
@@ -0,0 +1,122 @@
+-- Copyright (C) 2015 Yousong Zhou <yszhou4tech@gmail.com>
+-- Licensed to the public under the Apache License 2.0.
+
+local map, section, net = ...
+
+local sshuser, server, port, ssh_options, identity, ipaddr, peeraddr
+
+sshuser = section:taboption("general", Value, "sshuser", translate("SSH username"))
+
+server = section:taboption("general", Value, "server", translate("SSH server address"))
+server.datatype = "host(0)"
+
+port = section:taboption("general", Value, "port", translate("SSH server port"))
+port.datatype = "port"
+port.optional = true
+port.default = 22
+
+ssh_options = section:taboption("general", Value, "ssh_options", translate("Extra SSH command options"))
+ssh_options.optional = true
+
+identity = section:taboption("general", DynamicList, "identity", translate("List of SSH key files for auth"))
+identity.optional = true
+identity.datatype = "file"
+
+ipaddr = section:taboption("general", Value, "ipaddr", translate("Local IP address to assign"))
+ipaddr.datatype = "ipaddr"
+
+peeraddr = section:taboption("general", Value, "peeraddr", translate("Peer IP address to assign"))
+peeraddr.datatype = "ipaddr"
+
+
+local ipv6, defaultroute, metric, peerdns, dns,
+ keepalive_failure, keepalive_interval, demand
+
+if luci.model.network:has_ipv6() then
+ ipv6 = section:taboption("advanced", Flag, "ipv6",
+ translate("Enable IPv6 negotiation on the PPP link"))
+ ipv6.default = ipv6.disabled
+end
+
+
+defaultroute = section:taboption("advanced", Flag, "defaultroute",
+ translate("Use default gateway"),
+ translate("If unchecked, no default route is configured"))
+
+defaultroute.default = defaultroute.enabled
+
+
+metric = section:taboption("advanced", Value, "metric",
+ translate("Use gateway metric"))
+
+metric.placeholder = "0"
+metric.datatype = "uinteger"
+metric:depends("defaultroute", defaultroute.enabled)
+
+
+peerdns = section:taboption("advanced", Flag, "peerdns",
+ translate("Use DNS servers advertised by peer"),
+ translate("If unchecked, the advertised DNS server addresses are ignored"))
+
+peerdns.default = peerdns.enabled
+
+
+dns = section:taboption("advanced", DynamicList, "dns",
+ translate("Use custom DNS servers"))
+
+dns:depends("peerdns", "")
+dns.datatype = "ipaddr"
+dns.cast = "string"
+
+
+keepalive_failure = section:taboption("advanced", Value, "_keepalive_failure",
+ translate("LCP echo failure threshold"),
+ translate("Presume peer to be dead after given amount of LCP echo failures, use 0 to ignore failures"))
+
+function keepalive_failure.cfgvalue(self, section)
+ local v = m:get(section, "keepalive")
+ if v and #v > 0 then
+ return tonumber(v:match("^(%d+)[ ,]+%d+") or v)
+ end
+end
+
+function keepalive_failure.write() end
+function keepalive_failure.remove() end
+
+keepalive_failure.placeholder = "0"
+keepalive_failure.datatype = "uinteger"
+
+
+keepalive_interval = section:taboption("advanced", Value, "_keepalive_interval",
+ translate("LCP echo interval"),
+ translate("Send LCP echo requests at the given interval in seconds, only effective in conjunction with failure threshold"))
+
+function keepalive_interval.cfgvalue(self, section)
+ local v = m:get(section, "keepalive")
+ if v and #v > 0 then
+ return tonumber(v:match("^%d+[ ,]+(%d+)"))
+ end
+end
+
+function keepalive_interval.write(self, section, value)
+ local f = tonumber(keepalive_failure:formvalue(section)) or 0
+ local i = tonumber(value) or 5
+ if i < 1 then i = 1 end
+ if f > 0 then
+ m:set(section, "keepalive", "%d %d" %{ f, i })
+ else
+ m:del(section, "keepalive")
+ end
+end
+
+keepalive_interval.remove = keepalive_interval.write
+keepalive_interval.placeholder = "5"
+keepalive_interval.datatype = "min(1)"
+
+
+demand = section:taboption("advanced", Value, "demand",
+ translate("Inactivity timeout"),
+ translate("Close inactive connection after the given amount of seconds, use 0 to persist connection"))
+
+demand.placeholder = "0"
+demand.datatype = "uinteger"
diff --git a/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pptp.lua b/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pptp.lua
index d81db1faee..462d7019f0 100644
--- a/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pptp.lua
+++ b/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pptp.lua
@@ -9,7 +9,7 @@ local defaultroute, metric, peerdns, dns,
server = section:taboption("general", Value, "server", translate("VPN Server"))
-server.datatype = "host"
+server.datatype = "host(0)"
username = section:taboption("general", Value, "username", translate("PAP/CHAP username"))
diff --git a/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua b/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua
index e84658c703..7bbd78fa1e 100644
--- a/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua
+++ b/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua
@@ -4,7 +4,7 @@
local netmod = luci.model.network
local _, p
-for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "3g", "l2tp"}) do
+for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "3g", "l2tp", "pppossh"}) do
local proto = netmod:register_protocol(p)
@@ -21,6 +21,8 @@ for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "3g", "l2tp"}) do
return luci.i18n.translate("PPPoATM")
elseif p == "l2tp" then
return luci.i18n.translate("L2TP")
+ elseif p == "pppossh" then
+ return luci.i18n.translate("PPPoSSH")
end
end
@@ -41,6 +43,8 @@ for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "3g", "l2tp"}) do
return "ppp-mod-pppoa"
elseif p == "l2tp" then
return "xl2tpd"
+ elseif p == "pppossh" then
+ return "pppossh"
end
end
@@ -55,6 +59,8 @@ for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "3g", "l2tp"}) do
return nixio.fs.access("/lib/netifd/proto/3g.sh")
elseif p == "l2tp" then
return nixio.fs.access("/lib/netifd/proto/l2tp.sh")
+ elseif p == "pppossh" then
+ return nixio.fs.access("/lib/netifd/proto/pppossh.sh")
else
return nixio.fs.access("/lib/netifd/proto/ppp.sh")
end
diff --git a/protocols/luci-proto-vpnc/Makefile b/protocols/luci-proto-vpnc/Makefile
new file mode 100644
index 0000000000..9c77e67a5c
--- /dev/null
+++ b/protocols/luci-proto-vpnc/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=Support for VPNC VPN
+LUCI_DEPENDS:=+vpnc
+LUCI_PKGARCH:=all
+
+PKG_NAME:=luci-proto-vpnc
+PKG_RELEASE=1
+PKG_VERSION:=1.0.0
+PKG_MAINTAINER:=Daniel Dickinson <openwrt@daniel.thecshore.com>
+PKG_LICENSE:=Apache-2.0
+
+LUA_TARGET:=source
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature \ No newline at end of file
diff --git a/protocols/luci-proto-vpnc/luasrc/model/cbi/admin_network/proto_vpnc.lua b/protocols/luci-proto-vpnc/luasrc/model/cbi/admin_network/proto_vpnc.lua
new file mode 100644
index 0000000000..e450470eb3
--- /dev/null
+++ b/protocols/luci-proto-vpnc/luasrc/model/cbi/admin_network/proto_vpnc.lua
@@ -0,0 +1,82 @@
+-- Copyright 2015 Daniel Dickinson <openwrt@daniel.thecshore.com>
+-- Licensed to the public under the Apache License 2.0.
+
+local map, section, net = ...
+
+local server, username, password, hexpassword
+local authgroup, interface, passgroup, hexpassgroup
+local domain, vendor, natt_mode, dh_group
+local pfs, enable_single_des, enable_no_enc
+local mtu, local_addr, local_port, dpd_idle
+local auth_mode, target_network
+
+local ifc = net:get_interface():name()
+
+server = section:taboption("general", Value, "server", translate("VPN Server"))
+server.datatype = "host(0)"
+
+port = section:taboption("general", Value, "local_addr", translate("VPN Local address"))
+port.placeholder = "0.0.0.0"
+port.datatype = "ipaddr"
+
+port = section:taboption("general", Value, "local_port", translate("VPN Local port"))
+port.placeholder = "500"
+port.datatype = "port"
+
+ifname = section:taboption("general", Value, "interface", translate("Output Interface"))
+ifname.template = "cbi/network_netlist"
+
+mtu = section.taboption("general", Value, "mtu", translate("MTU"))
+mtu.datatype = "uinteger"
+
+section:taboption("general", Value, "authgroup", translate("AuthGroup"))
+
+username = section:taboption("general", Value, "username", translate("Username"))
+password = section:taboption("general", Value, "password", translate("Password"))
+hexpassword = section:taboption("general", Value, "hexpassword", translate("Obfuscated Password"))
+password.password = true
+hexpassword.password = true
+authroup = section:taboption("general", Value, "authgroup", translate("Auth Group"))
+passgroup = section:taboption("general", Value, "passgroup", translate("Group Password"))
+hexpassgroup = section:taboption("general", Value, "hexpassgroup", translate("Obfuscated Group Password"))
+password.passgroup = true
+hexpassword.passgroup= true
+
+domain = section:taboption("general", Value, "domain", translate("NT Domain"))
+vendor = section:taboption("general", Value, "vendor", translate("Vendor"))
+dh_group = section:taboption("general", ListValue, "dh_group", translate("IKE DH Group"))
+dh_group:value("dh2")
+dh_group:value("dh1")
+dh_group:value("dh5")
+
+pfs = section:taboption("general", ListValue, "pfs", translate("Perfect Forward Secrecy"))
+dh_group:value("server")
+dh_group:value("nopfs")
+dh_group:value("dh1")
+dh_group:value("dh2")
+dh_group:value("dh5")
+
+natt_mode = section:taboption("general", ListValue, "natt_mode", translate("NAT-T Mode")
+natt_mode:value("natt", translate("RFC3947 NAT-T mode"))
+natt_mode:value("none", translate("No NAT-T"))
+natt_mode:value("force-natt", translate("Force use of NAT-T")
+natt_mode:value("cisco-udp", translate("Cisco UDP encapsulation")
+
+enable_no_enc = section:taboption("general", Flag, "enable_no_enc",
+ translate("Disable Encryption"),
+ translate("If checked, encryption is disabled"))
+enable_no_enc.default = enable_no_enc.disabled
+
+enable_single_des = section:taboption("general", Flag, "enable_single_des",
+ translate("Enable Single DES"),
+ translate("If checked, 1DES is enaled"))
+enable_no_enc.default = enable_single_des.disabled
+
+dpd_idle = section.taboption("general", Value, "dpd_idle", translate("DPD Idle Timeout"))
+dpd_idle.datatype = "uinteger"
+dpd.placeholder = "600"
+
+ifname = section:taboption("general", Value, "target_network", translate("Target network"))
+port.placeholder = "0.0.0.0/0"
+port.datatype = "network"
+
diff --git a/protocols/luci-proto-vpnc/luasrc/model/network/proto_vpnc.lua b/protocols/luci-proto-vpnc/luasrc/model/network/proto_vpnc.lua
new file mode 100644
index 0000000000..f4cae0bd2a
--- /dev/null
+++ b/protocols/luci-proto-vpnc/luasrc/model/network/proto_vpnc.lua
@@ -0,0 +1,46 @@
+-- Copyright 2015 Daniel Dickinson <openwrt@daniel.thecshore.com>
+-- Licensed to the public under the Apache License 2.0.
+
+local netmod = luci.model.network
+local interface = luci.model.network.interface
+local proto = netmod:register_protocol("vpnc")
+
+function proto.get_i18n(self)
+ return luci.i18n.translate("VPNC (CISCO 3000 (and others) VPN)")
+end
+
+function proto.ifname(self)
+ return "vpn-" .. self.sid
+end
+
+function proto.get_interface(self)
+ return interface(self:ifname(), self)
+end
+
+function proto.opkg_package(self)
+ return "vpnc"
+end
+
+function proto.is_installed(self)
+ return nixio.fs.access("/lib/netifd/proto/vpnc.sh")
+end
+
+function proto.is_floating(self)
+ return true
+end
+
+function proto.is_virtual(self)
+ return true
+end
+
+function proto.get_interfaces(self)
+ return nil
+end
+
+function proto.contains_interface(self, ifc)
+ return (netmod:ifnameof(ifc) == self:ifname())
+
+end
+
+netmod:register_pattern_virtual("^vpn-%w")
+