summaryrefslogtreecommitdiffhomepage
path: root/protocols
diff options
context:
space:
mode:
Diffstat (limited to 'protocols')
-rw-r--r--protocols/luci-proto-3g/luasrc/model/cbi/admin_network/proto_3g.lua4
-rw-r--r--protocols/luci-proto-hnet/Makefile17
-rw-r--r--protocols/luci-proto-hnet/luasrc/model/cbi/admin_network/proto_hnet.lua (renamed from protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_hnet.lua)0
-rw-r--r--protocols/luci-proto-hnet/luasrc/model/network/proto_hnet.lua (renamed from protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua)0
-rw-r--r--protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua8
-rw-r--r--protocols/luci-proto-pppossh/Makefile17
-rw-r--r--protocols/luci-proto-pppossh/luasrc/model/cbi/admin_network/proto_pppossh.lua (renamed from protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pppossh.lua)0
-rw-r--r--protocols/luci-proto-pppossh/luasrc/model/network/proto_pppossh.lua40
-rw-r--r--protocols/luci-proto-wireguard/Makefile2
9 files changed, 78 insertions, 10 deletions
diff --git a/protocols/luci-proto-3g/luasrc/model/cbi/admin_network/proto_3g.lua b/protocols/luci-proto-3g/luasrc/model/cbi/admin_network/proto_3g.lua
index 1b2e23cc42..e05e3a47fd 100644
--- a/protocols/luci-proto-3g/luasrc/model/cbi/admin_network/proto_3g.lua
+++ b/protocols/luci-proto-3g/luasrc/model/cbi/admin_network/proto_3g.lua
@@ -47,7 +47,9 @@ dialnumber.placeholder = "*99***1#"
if luci.model.network:has_ipv6() then
- ipv6 = section:taboption("advanced", ListValue, "ipv6")
+ ipv6 = section:taboption("advanced", ListValue, "ipv6",
+ translate("Obtain IPv6-Address"))
+
ipv6:value("auto", translate("Automatic"))
ipv6:value("0", translate("Disabled"))
ipv6:value("1", translate("Manual"))
diff --git a/protocols/luci-proto-hnet/Makefile b/protocols/luci-proto-hnet/Makefile
new file mode 100644
index 0000000000..10beb032bc
--- /dev/null
+++ b/protocols/luci-proto-hnet/Makefile
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2018 Florian Eckert <fe@dev.tdt.de>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=Support for hnet
+LUCI_DEPENDS:=
+
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_hnet.lua b/protocols/luci-proto-hnet/luasrc/model/cbi/admin_network/proto_hnet.lua
index 2ed34faf71..2ed34faf71 100644
--- a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_hnet.lua
+++ b/protocols/luci-proto-hnet/luasrc/model/cbi/admin_network/proto_hnet.lua
diff --git a/protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua b/protocols/luci-proto-hnet/luasrc/model/network/proto_hnet.lua
index f525061be4..f525061be4 100644
--- a/protocols/luci-proto-ipv6/luasrc/model/network/proto_hnet.lua
+++ b/protocols/luci-proto-hnet/luasrc/model/network/proto_hnet.lua
diff --git a/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua b/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua
index 3afb7de4f5..f87b30fcc1 100644
--- a/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua
+++ b/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua
@@ -4,7 +4,7 @@
local netmod = luci.model.network
local _, p
-for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "l2tp", "pppossh"}) do
+for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "l2tp"}) do
local proto = netmod:register_protocol(p)
@@ -19,8 +19,6 @@ for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "l2tp", "pppossh"}) do
return luci.i18n.translate("PPPoATM")
elseif p == "l2tp" then
return luci.i18n.translate("L2TP")
- elseif p == "pppossh" then
- return luci.i18n.translate("PPPoSSH")
end
end
@@ -39,8 +37,6 @@ for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "l2tp", "pppossh"}) do
return "ppp-mod-pppoa"
elseif p == "l2tp" then
return "xl2tpd"
- elseif p == "pppossh" then
- return "pppossh"
end
end
@@ -53,8 +49,6 @@ for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "l2tp", "pppossh"}) do
return (nixio.fs.glob("/usr/lib/pppd/*/pptp.so")() ~= nil)
elseif p == "l2tp" then
return nixio.fs.access("/lib/netifd/proto/l2tp.sh")
- elseif p == "pppossh" then
- return nixio.fs.access("/lib/netifd/proto/pppossh.sh")
else
return nixio.fs.access("/lib/netifd/proto/ppp.sh")
end
diff --git a/protocols/luci-proto-pppossh/Makefile b/protocols/luci-proto-pppossh/Makefile
new file mode 100644
index 0000000000..1c0a63b0f2
--- /dev/null
+++ b/protocols/luci-proto-pppossh/Makefile
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2018 Florian Eckert <fe@dev.tdt.de>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=Support for pppossh
+LUCI_DEPENDS:=+pppossh
+
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pppossh.lua b/protocols/luci-proto-pppossh/luasrc/model/cbi/admin_network/proto_pppossh.lua
index e53262b5dc..e53262b5dc 100644
--- a/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pppossh.lua
+++ b/protocols/luci-proto-pppossh/luasrc/model/cbi/admin_network/proto_pppossh.lua
diff --git a/protocols/luci-proto-pppossh/luasrc/model/network/proto_pppossh.lua b/protocols/luci-proto-pppossh/luasrc/model/network/proto_pppossh.lua
new file mode 100644
index 0000000000..a0e2a510c9
--- /dev/null
+++ b/protocols/luci-proto-pppossh/luasrc/model/network/proto_pppossh.lua
@@ -0,0 +1,40 @@
+-- Copyright 2018 Florian Eckert <fe@dev.tdt.de>
+-- Licensed to the public under the Apache License 2.0.
+
+local netmod = luci.model.network
+
+local proto = netmod:register_protocol("pppossh")
+
+function proto.get_i18n(self)
+ return luci.i18n.translate("PPPoSSH")
+end
+
+function proto.ifname(self)
+ return "pppossh-" .. self.sid
+end
+
+function proto.opkg_package(self)
+ return "pppossh"
+end
+
+function proto.is_installed(self)
+ return nixio.fs.access("/lib/netifd/proto/pppossh.sh")
+end
+
+function proto.is_floating(self)
+ return true
+end
+
+function proto.is_virtual(self)
+ return true
+end
+
+function proto.get_interfaces(self)
+ return nil
+end
+
+function proto.contains_interface(self, ifc)
+ return (netmod:ifnameof(ifc) == self:ifname())
+end
+
+netmod:register_pattern_virtual("^pppossh%-%w")
diff --git a/protocols/luci-proto-wireguard/Makefile b/protocols/luci-proto-wireguard/Makefile
index 0dc70cf31e..3540a74acd 100644
--- a/protocols/luci-proto-wireguard/Makefile
+++ b/protocols/luci-proto-wireguard/Makefile
@@ -10,8 +10,6 @@ LUCI_TITLE:=Support for WireGuard VPN
LUCI_DEPENDS:=+kmod-wireguard +wireguard-tools
LUCI_PKGARCH:=all
-PKG_MAINTAINER:=Dan Luedtke <mail@danrl.com>
-
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature