summaryrefslogtreecommitdiffhomepage
path: root/protocols/luci-proto-yggdrasil
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/luci-proto-yggdrasil')
-rw-r--r--protocols/luci-proto-yggdrasil/Makefile3
-rw-r--r--protocols/luci-proto-yggdrasil/htdocs/luci-static/resources/protocol/yggdrasil.js5
2 files changed, 7 insertions, 1 deletions
diff --git a/protocols/luci-proto-yggdrasil/Makefile b/protocols/luci-proto-yggdrasil/Makefile
index 1025cb67ca..c864ac4aa2 100644
--- a/protocols/luci-proto-yggdrasil/Makefile
+++ b/protocols/luci-proto-yggdrasil/Makefile
@@ -9,7 +9,8 @@ include $(TOPDIR)/rules.mk
LUCI_TITLE:=Support for Yggdrasil Network
LUCI_DEPENDS:=+yggdrasil
LUCI_PKGARCH:=all
-PKG_VERSION:=1.1.0
+PKG_VERSION:=1.1.1
+PKG_MAINTAINER:=William Fleurant <meshnet@protonmail.com>
include ../../luci.mk
diff --git a/protocols/luci-proto-yggdrasil/htdocs/luci-static/resources/protocol/yggdrasil.js b/protocols/luci-proto-yggdrasil/htdocs/luci-static/resources/protocol/yggdrasil.js
index d02095beb4..f216f8b16f 100644
--- a/protocols/luci-proto-yggdrasil/htdocs/luci-static/resources/protocol/yggdrasil.js
+++ b/protocols/luci-proto-yggdrasil/htdocs/luci-static/resources/protocol/yggdrasil.js
@@ -98,6 +98,10 @@ function updateActivePeers(ifname) {
cell = row.insertCell(-1)
cell.className = "td"
+ cell.textContent = '%.2f ms'.format(peer.latency_ms / 10**6);
+
+ cell = row.insertCell(-1)
+ cell.className = "td"
cell.textContent = '%.2mB'.format(peer.bytes_recvd);
cell = row.insertCell(-1)
@@ -136,6 +140,7 @@ var cbiActivePeers = form.DummyValue.extend({
E('th', {'class': 'th'}, _('Dir')),
E('th', {'class': 'th'}, _('IP Address')),
E('th', {'class': 'th'}, _('Uptime')),
+ E('th', {'class': 'th'}, _('Latency')),
E('th', {'class': 'th'}, _('RX')),
E('th', {'class': 'th'}, _('TX')),
E('th', {'class': 'th'}, _('Priority')),