summaryrefslogtreecommitdiffhomepage
path: root/protocols/luci-proto-ipv6
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/luci-proto-ipv6')
-rw-r--r--protocols/luci-proto-ipv6/Makefile4
-rw-r--r--protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_6in4.lua2
-rw-r--r--protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua136
-rw-r--r--protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_dhcpv6.lua2
-rw-r--r--protocols/luci-proto-ipv6/luasrc/model/network/proto_4x6.lua17
-rw-r--r--protocols/luci-proto-ipv6/luasrc/model/network/proto_6x4.lua2
-rw-r--r--protocols/luci-proto-ipv6/luasrc/model/network/proto_aiccu.lua49
7 files changed, 15 insertions, 197 deletions
diff --git a/protocols/luci-proto-ipv6/Makefile b/protocols/luci-proto-ipv6/Makefile
index e749bc9e83..b28c8d5895 100644
--- a/protocols/luci-proto-ipv6/Makefile
+++ b/protocols/luci-proto-ipv6/Makefile
@@ -6,9 +6,11 @@
include $(TOPDIR)/rules.mk
-LUCI_TITLE:=Support for DHCPv6/6in4/6to4/6rd/DS-Lite/aiccu
+LUCI_TITLE:=Support for DHCPv6/6in4/6to4/6rd/DS-Lite
LUCI_DEPENDS:=
+PKG_LICENSE:=Apache-2.0
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature
diff --git a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_6in4.lua b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_6in4.lua
index 88dfe09289..16245b80e5 100644
--- a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_6in4.lua
+++ b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_6in4.lua
@@ -24,7 +24,7 @@ peeraddr.datatype = "ip4addr"
ip6addr = s:taboption("general", Value, "ip6addr",
translate("Local IPv6 address"),
- translate("This is the local endpoint address assigned by the tunnel broker, it usually ends with <code>:2</code>"))
+ translate("This is the local endpoint address assigned by the tunnel broker, it usually ends with <code>...:2/64</code>"))
ip6addr.datatype = "ip6addr"
diff --git a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua
deleted file mode 100644
index 7b5e6043cc..0000000000
--- a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_aiccu.lua
+++ /dev/null
@@ -1,136 +0,0 @@
--- Copyright 2015 Paul Oranje <por@xs4all.nl>
--- Licensed to the public under the Apache License 2.0.
-
-local map, section, net = ...
-
--- config read by /lib/netifd/proto/aiccu.sh
-local username, password, protocol, server, tunnelid, ip6prefix, requiretls, nat, heartbeat,
- verbose, ntpsynctimeout, ip6addr, sourcerouting, defaultroute
-
--- generic parameters
-local metric, ttl, mtu
-
-
-username = section:taboption("general", Value, "username",
- translate("Server username"),
- translate("SIXXS-handle[/Tunnel-ID]"))
-username.datatype = "string"
-
-password = section:taboption("general", Value, "password",
- translate("Server password"),
- translate("Server password, enter the specific password of the tunnel when the username contains the tunnel ID"))
-password.datatype = "string"
-password.password = true
-
-
---[[ SIXXS supports only TIC as tunnel broker protocol, no use setting it.
-protocol = section:taboption("general", ListValue, "protocol",
- translate("Tunnel broker protocol"),
- translate("SIXXS supports TIC only, for static tunnels using IP protocol 41 (RFC4213) use 6in4 instead"))
-
-protocol:value("tic", "TIC")
-protocol:value("tsp", "TSP")
-protocol:value("l2tp", "L2TP")
-protocol.default = "tic"
-protocol.optional = true
---]]
-
-
-server = section:taboption("general", Value, "server",
- translate("Tunnel setup server"),
- translate("Optional, specify to override default server (tic.sixxs.net)"))
-server.datatype = "host(0)"
-server.optional = true
-
-
-tunnelid = section:taboption("general", Value, "tunnelid",
- translate("Tunnel ID"),
- translate("Optional, use when the SIXXS account has more than one tunnel"))
-tunnelid.datatype = "string"
-tunnelid.optional = true
-
-
-local ip6prefix = section:taboption("general", Value, "ip6prefix",
- translate("IPv6 prefix"),
- translate("Routed IPv6 prefix for downstream interfaces"))
-ip6prefix.datatype = "ip6addr"
-ip6prefix.optional = true
-
-
-heartbeat = s:taboption("general", ListValue, "heartbeat",
- translate("Tunnel type"),
- translate("Also see <a href=\"https://www.sixxs.net/faq/connectivity/?faq=comparison\">Tunneling Comparison</a> on SIXXS"))
-heartbeat:value("0", translate("AYIYA"))
-heartbeat:value("1", translate("Heartbeat"))
-heartbeat.default = "0"
-
-
-nat = section:taboption("general", Flag, "nat",
- translate("Behind NAT"),
- translate("The tunnel end-point is behind NAT, defaults to disabled and only applies to AYIYA"))
-nat.optional = true
-nat.default = nat.disabled
-
-
-requiretls = section:taboption("general", Flag, "requiretls",
- translate("Require TLS"),
- translate("Connection to server fails when TLS cannot be used"))
-requiretls.optional = true
-requiretls.default = requiretls.disabled
-
-
-verbose = section:taboption("advanced", Flag, "verbose",
- translate("Verbose"),
- translate("Verbose logging by aiccu daemon"))
-verbose.optional = true
-verbose.default = verbose.disabled
-
-
-ntpsynctimeout = section:taboption("advanced", Value, "ntpsynctimeout",
- translate("NTP sync time-out"),
- translate("Wait for NTP sync that many seconds, seting to 0 disables waiting (optional)"))
-ntpsynctimeout.datatype = "uinteger"
-ntpsynctimeout.placeholder = "90"
-ntpsynctimeout.optional = true
-
-
-ip6addr = section:taboption("advanced", Value, "ip6addr",
- translate("Local IPv6 address"),
- translate("IPv6 address delegated to the local tunnel endpoint (optional)"))
-ip6addr.datatype = "ip6addr"
-ip6addr.optional = true
-
-
-defaultroute = section:taboption("advanced", Flag, "defaultroute",
- translate("Default route"),
- translate("Whether to create an IPv6 default route over the tunnel"))
-defaultroute.default = defaultroute.enabled
-defaultroute.optional = true
-
-
-sourcerouting = section:taboption("advanced", Flag, "sourcerouting",
- translate("Source routing"),
- translate("Whether to route only packets from delegated prefixes"))
-sourcerouting.default = sourcerouting.enabled
-sourcerouting.optional = true
-
-
-metric = section:taboption("advanced", Value, "metric",
- translate("Use gateway metric"))
-metric.datatype = "uinteger"
-metric.placeholder = "0"
-metric:depends("defaultroute", defaultroute.enabled)
-
-
-ttl = section:taboption("advanced", Value, "ttl",
- translate("Use TTL on tunnel interface"))
-ttl.datatype = "range(1,255)"
-ttl.placeholder = "64"
-
-
-mtu = section:taboption("advanced", Value, "mtu",
- translate("Use MTU on tunnel interface"),
- translate("minimum 1280, maximum 1480"))
-mtu.datatype = "range(1280,1480)"
-mtu.placeholder = "1280"
-
diff --git a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_dhcpv6.lua b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_dhcpv6.lua
index c843161c6f..76caedcb37 100644
--- a/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_dhcpv6.lua
+++ b/protocols/luci-proto-ipv6/luasrc/model/cbi/admin_network/proto_dhcpv6.lua
@@ -14,7 +14,7 @@ o.default = "try"
o = section:taboption("general", Value, "reqprefix",
translate("Request IPv6-prefix of length"))
-o:value("auto", translate("automatic"))
+o:value("auto", translate("Automatic"))
o:value("no", translate("disabled"))
o:value("48")
o:value("52")
diff --git a/protocols/luci-proto-ipv6/luasrc/model/network/proto_4x6.lua b/protocols/luci-proto-ipv6/luasrc/model/network/proto_4x6.lua
index d876d69ba8..7508e0d4b0 100644
--- a/protocols/luci-proto-ipv6/luasrc/model/network/proto_4x6.lua
+++ b/protocols/luci-proto-ipv6/luasrc/model/network/proto_4x6.lua
@@ -52,12 +52,13 @@ for _, p in ipairs({"dslite", "map", "464xlat"}) do
function proto.contains_interface(self, ifname)
return (netmod:ifnameof(ifc) == self:ifname())
end
-
- if p == "dslite" then
- netmod:register_pattern_virtual("^ds-%w")
- elseif p == "map" then
- netmod:register_pattern_virtual("^map-%w")
- elseif p == "464xlat" then
- netmod:register_pattern_virtual("^464-%w")
- end
end
+
+netmod:register_pattern_virtual("^464%-%w")
+netmod:register_pattern_virtual("^ds%-%w")
+netmod:register_pattern_virtual("^map%-%w")
+
+netmod:register_error_code("AFTR_DNS_FAIL", luci.i18n.translate("Unable to resolve AFTR host name"))
+netmod:register_error_code("INVALID_MAP_RULE", luci.i18n.translate("MAP rule is invalid"))
+netmod:register_error_code("NO_MATCHING_PD", luci.i18n.translate("No matching prefix delegation"))
+netmod:register_error_code("UNSUPPORTED_TYPE", luci.i18n.translate("Unsupported MAP type"))
diff --git a/protocols/luci-proto-ipv6/luasrc/model/network/proto_6x4.lua b/protocols/luci-proto-ipv6/luasrc/model/network/proto_6x4.lua
index d267ce9119..9a4396c5be 100644
--- a/protocols/luci-proto-ipv6/luasrc/model/network/proto_6x4.lua
+++ b/protocols/luci-proto-ipv6/luasrc/model/network/proto_6x4.lua
@@ -46,5 +46,5 @@ for _, p in ipairs({"6in4", "6to4", "6rd"}) do
return (netmod:ifnameof(ifc) == self:ifname())
end
- netmod:register_pattern_virtual("^%s-%%w" % p)
+ netmod:register_pattern_virtual("^%s%%-%%w" % p)
end
diff --git a/protocols/luci-proto-ipv6/luasrc/model/network/proto_aiccu.lua b/protocols/luci-proto-ipv6/luasrc/model/network/proto_aiccu.lua
deleted file mode 100644
index 5896a278ce..0000000000
--- a/protocols/luci-proto-ipv6/luasrc/model/network/proto_aiccu.lua
+++ /dev/null
@@ -1,49 +0,0 @@
--- Copyright 2015 Paul Oranje <por@xs4all.nl>
--- Licensed to the public under GPLv2
-
-local netmod = luci.model.network
-local interface = luci.model.network.interface
-
-local proto = netmod:register_protocol("aiccu")
-
-function proto.get_i18n(self)
- return luci.i18n.translate("AICCU (SIXXS)")
-end
-
-function proto.ifname(self)
- return "aiccu-" .. self.sid
-end
-
-function proto.get_interface(self)
- return interface(self:ifname(), self)
-end
-
-function proto.is_installed(self)
- return nixio.fs.access("/lib/netifd/proto/aiccu.sh")
-end
-
-function proto.opkg_package(self)
- return "aiccu"
-end
-
-function proto.is_floating(self)
- return true
-end
-
-function proto.is_virtual(self)
- return true
-end
-
-function proto.get_interfaces(self)
- return nil
-end
-
-function proto.contains_interface(self, ifname)
- if self:is_floating() then
- return (netmod:ifnameof(ifc) == self:ifname())
- else
- return netmod.protocol.contains_interface(self, ifc)
- end
-end
-
-netmod:register_pattern_virtual("^aiccu-%%w")