summaryrefslogtreecommitdiffhomepage
path: root/protocols/luci-proto-hnet
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/luci-proto-hnet')
-rw-r--r--protocols/luci-proto-hnet/Makefile17
-rw-r--r--protocols/luci-proto-hnet/luasrc/model/cbi/admin_network/proto_hnet.lua37
-rw-r--r--protocols/luci-proto-hnet/luasrc/model/network/proto_hnet.lua16
3 files changed, 70 insertions, 0 deletions
diff --git a/protocols/luci-proto-hnet/Makefile b/protocols/luci-proto-hnet/Makefile
new file mode 100644
index 000000000..10beb032b
--- /dev/null
+++ b/protocols/luci-proto-hnet/Makefile
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2018 Florian Eckert <fe@dev.tdt.de>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=Support for hnet
+LUCI_DEPENDS:=
+
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/protocols/luci-proto-hnet/luasrc/model/cbi/admin_network/proto_hnet.lua b/protocols/luci-proto-hnet/luasrc/model/cbi/admin_network/proto_hnet.lua
new file mode 100644
index 000000000..2ed34faf7
--- /dev/null
+++ b/protocols/luci-proto-hnet/luasrc/model/cbi/admin_network/proto_hnet.lua
@@ -0,0 +1,37 @@
+-- Copyright 2013 Steven Barth <steven@midlink.org>
+-- Licensed to the public under the Apache License 2.0.
+
+local map, section, net = ...
+
+local mode = section:taboption("general", ListValue, "mode", translate("Category"))
+mode:value("auto", translate("Automatic"))
+mode:value("external", translate("External"))
+mode:value("internal", translate("Internal"))
+mode:value("leaf", translate("Leaf"))
+mode:value("guest", translate("Guest"))
+mode:value("adhoc", translate("Ad-Hoc"))
+mode:value("hybrid", translate("Hybrid"))
+mode.default = "auto"
+
+
+
+local plen = section:taboption("advanced", Value, "ip6assign", translate("IPv6 assignment length"),
+ translate("Assign a part of given length of every public IPv6-prefix to this interface"))
+plen.datatype = "max(128)"
+plen.default = "64"
+
+section:taboption("advanced", Value, "link_id", translate("IPv6 assignment hint"),
+ translate("Assign prefix parts using this hexadecimal subprefix ID for this interface."))
+
+plen = section:taboption("advanced", Value, "ip4assign", translate("IPv4 assignment length"))
+plen.datatype = "max(32)"
+plen.default = "24"
+
+local o = section:taboption("advanced", Value, "dnsname", translate("DNS-Label / FQDN"))
+o.default = map.name
+
+luci.tools.proto.opt_macaddr(section, ifc, translate("Override MAC address"))
+
+o = section:taboption("advanced", Value, "mtu", translate("Override MTU"))
+o.placeholder = "1500"
+o.datatype = "max(9200)"
diff --git a/protocols/luci-proto-hnet/luasrc/model/network/proto_hnet.lua b/protocols/luci-proto-hnet/luasrc/model/network/proto_hnet.lua
new file mode 100644
index 000000000..f525061be
--- /dev/null
+++ b/protocols/luci-proto-hnet/luasrc/model/network/proto_hnet.lua
@@ -0,0 +1,16 @@
+-- Copyright 2014 Steven Barth <steven@midlink.org>
+-- Licensed to the public under the Apache License 2.0.
+
+local proto = luci.model.network:register_protocol("hnet")
+
+function proto.get_i18n(self)
+ return luci.i18n.translate("Automatic Homenet (HNCP)")
+end
+
+function proto.is_installed(self)
+ return nixio.fs.access("/lib/netifd/proto/hnet.sh")
+end
+
+function proto.opkg_package(self)
+ return "hnet-full"
+end