summaryrefslogtreecommitdiffhomepage
path: root/modules
diff options
context:
space:
mode:
Diffstat (limited to 'modules')
-rw-r--r--modules/luci-base/Makefile14
-rw-r--r--modules/luci-base/luasrc/view/cbi/tsection.htm5
-rw-r--r--modules/luci-mod-network/htdocs/luci-static/resources/view/network/network.js2
-rw-r--r--modules/luci-mod-status/htdocs/luci-static/resources/view/status/index.js39
-rw-r--r--modules/luci-mod-status/luasrc/view/admin_status/connections.htm4
5 files changed, 40 insertions, 24 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index 9bc8ec17a1..d94804529c 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -14,13 +14,17 @@ LUCI_BASENAME:=base
LUCI_TITLE:=LuCI core libraries
LUCI_DEPENDS:=+lua +luci-lib-nixio +luci-lib-ip +rpcd +libubus-lua +luci-lib-jsonc +liblucihttp-lua
-
-PKG_SOURCE:=v1.0.0.tar.gz
-PKG_SOURCE_URL:=https://github.com/jirutka/luasrcdiet/archive/
-PKG_HASH:=48162e63e77d009f5848f18a5cabffbdfc867d0e5e73c6d407f6af5d6880151b
+LUCI_LUASRCDIET_VERSION:=1.0.0
+
+PKG_SOURCE_URL:=https://github.com/jirutka/luasrcdiet.git
+PKG_SOURCE_VERSION:=f138fc9359821d9201cd6b57cfa2fcbed5b9af97
+PKG_SOURCE_SUBDIR:=luasrcdiet-$(LUCI_LUASRCDIET_VERSION)
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
+PKG_MIRROR_HASH:=a5c9d098549fbef618e6022b701e66c8c6fb16c910e63219adad3a4e71341f72
PKG_LICENSE:=MIT
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/luasrcdiet-1.0.0
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_SOURCE_SUBDIR)
include $(INCLUDE_DIR)/host-build.mk
diff --git a/modules/luci-base/luasrc/view/cbi/tsection.htm b/modules/luci-base/luasrc/view/cbi/tsection.htm
index 547a793329..8f3b7f0ffb 100644
--- a/modules/luci-base/luasrc/view/cbi/tsection.htm
+++ b/modules/luci-base/luasrc/view/cbi/tsection.htm
@@ -2,6 +2,11 @@
<% if self.title and #self.title > 0 then -%>
<legend><%=self.title%></legend>
<%- end %>
+ <% if self.error_msg and #self.error_msg > 0 then -%>
+ <div class="cbi-section-error">
+ <%=self.error_msg%>
+ </div>
+ <%- end %>
<% if self.description and #self.description > 0 then -%>
<div class="cbi-section-descr"><%=self.description%></div>
<%- end %>
diff --git a/modules/luci-mod-network/htdocs/luci-static/resources/view/network/network.js b/modules/luci-mod-network/htdocs/luci-static/resources/view/network/network.js
index 40624e741e..fe1ff19fed 100644
--- a/modules/luci-mod-network/htdocs/luci-static/resources/view/network/network.js
+++ b/modules/luci-mod-network/htdocs/luci-static/resources/view/network/network.js
@@ -1,7 +1,7 @@
function iface_reconnect(id) {
L.halt();
L.dom.content(document.getElementById(id + '-ifc-description'), E('em', _('Interface is reconnecting...')));
- L.post(L.url('admin/network/iface_reconnect', id), L.run);
+ L.post(L.url('admin/network/iface_reconnect', id), null, L.run);
}
function iface_delete(ev) {
diff --git a/modules/luci-mod-status/htdocs/luci-static/resources/view/status/index.js b/modules/luci-mod-status/htdocs/luci-static/resources/view/status/index.js
index c2aa3a9b0d..3a895eca18 100644
--- a/modules/luci-mod-status/htdocs/luci-static/resources/view/status/index.js
+++ b/modules/luci-mod-status/htdocs/luci-static/resources/view/status/index.js
@@ -1,13 +1,15 @@
-function progressbar(q, v, m)
+function progressbar(query, value, max, byte)
{
- var pg = document.querySelector(q),
- vn = parseInt(v) || 0,
- mn = parseInt(m) || 100,
+ var pg = document.querySelector(query),
+ vn = parseInt(value) || 0,
+ mn = parseInt(max) || 100,
+ fv = byte ? String.format('%1024.2mB', value) : value,
+ fm = byte ? String.format('%1024.2mB', max) : max,
pc = Math.floor((100 / mn) * vn);
if (pg) {
pg.firstElementChild.style.width = pc + '%';
- pg.setAttribute('title', '%s / %s (%d%%)'.format(v, m, pc));
+ pg.setAttribute('title', '%s / %s (%d%%)'.format(fv, fm, pc));
}
}
@@ -189,27 +191,32 @@ L.poll(5, L.location(), { status: 1 },
);
progressbar('#memtotal',
- ((info.memory.free + info.memory.buffered) / 1024) + ' ' + _('kB'),
- (info.memory.total / 1024) + ' ' + _('kB'));
+ info.memory.free + info.memory.buffered,
+ info.memory.total,
+ true);
progressbar('#memfree',
- (info.memory.free / 1024) + ' ' + _('kB'),
- (info.memory.total / 1024) + ' ' + _('kB'));
+ info.memory.free,
+ info.memory.total,
+ true);
progressbar('#membuff',
- (info.memory.buffered / 1024) + ' ' + _('kB'),
- (info.memory.total / 1024) + ' ' + _('kB'));
+ info.memory.buffered,
+ info.memory.total,
+ true);
progressbar('#swaptotal',
- (info.swap.free / 1024) + ' ' + _('kB'),
- (info.swap.total / 1024) + ' ' + _('kB'));
+ info.swap.free,
+ info.swap.total,
+ true);
progressbar('#swapfree',
- (info.swap.free / 1024) + ' ' + _('kB'),
- (info.swap.total / 1024) + ' ' + _('kB'));
+ info.swap.free,
+ info.swap.total,
+ true);
progressbar('#conns',
- info.conncount, info.connmax);
+ info.conncount, info.connmax, false);
}
);
diff --git a/modules/luci-mod-status/luasrc/view/admin_status/connections.htm b/modules/luci-mod-status/luasrc/view/admin_status/connections.htm
index d9099aa078..e3dd39d607 100644
--- a/modules/luci-mod-status/luasrc/view/admin_status/connections.htm
+++ b/modules/luci-mod-status/luasrc/view/admin_status/connections.htm
@@ -165,8 +165,8 @@
rows.push([
c.layer3.toUpperCase(),
c.layer4.toUpperCase(),
- src + ':' + c.sport,
- dst + ':' + c.dport,
+ c.hasOwnProperty('sport') ? (src + ':' + c.sport) : src,
+ c.hasOwnProperty('dport') ? (dst + ':' + c.dport) : dst,
'%1024.2mB (%d <%:Pkts.%>)'.format(c.bytes, c.packets)
]);
}