summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-lua-runtime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'modules/luci-lua-runtime/Makefile')
-rw-r--r--modules/luci-lua-runtime/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/luci-lua-runtime/Makefile b/modules/luci-lua-runtime/Makefile
new file mode 100644
index 0000000000..f25e513eb1
--- /dev/null
+++ b/modules/luci-lua-runtime/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2022 Jo-Philipp Wich <jo@mein.io>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=luci-lua-runtime
+
+LUCI_TYPE:=mod
+LUCI_BASENAME:=lua-runtime
+
+LUCI_TITLE:=LuCI Lua runtime libraries
+LUCI_DEPENDS:= \
+ +luci-base \
+ +lua \
+ +luci-lib-base \
+ +luci-lib-nixio \
+ +luci-lib-ip \
+ +luci-lib-jsonc \
+ +libubus-lua \
+ +liblucihttp-lua \
+ +ucode-mod-lua
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature