summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base
diff options
context:
space:
mode:
Diffstat (limited to 'modules/luci-base')
-rw-r--r--modules/luci-base/Makefile1
-rw-r--r--modules/luci-base/htdocs/luci-static/resources/cbi.js11
-rw-r--r--modules/luci-base/htdocs/luci-static/resources/xhr.js2
-rw-r--r--modules/luci-base/luasrc/dispatcher.lua17
-rw-r--r--modules/luci-base/luasrc/sys.lua4
-rw-r--r--modules/luci-base/po/ca/base.po3
-rw-r--r--modules/luci-base/po/cs/base.po3
-rw-r--r--modules/luci-base/po/de/base.po3
-rw-r--r--modules/luci-base/po/el/base.po3
-rw-r--r--modules/luci-base/po/en/base.po3
-rw-r--r--modules/luci-base/po/es/base.po3
-rw-r--r--modules/luci-base/po/fr/base.po3
-rw-r--r--modules/luci-base/po/he/base.po3
-rw-r--r--modules/luci-base/po/hu/base.po3
-rw-r--r--modules/luci-base/po/it/base.po3
-rw-r--r--modules/luci-base/po/ja/base.po29
-rw-r--r--modules/luci-base/po/ko/base.po3
-rw-r--r--modules/luci-base/po/ms/base.po3
-rw-r--r--modules/luci-base/po/no/base.po3
-rw-r--r--modules/luci-base/po/pl/base.po3
-rw-r--r--modules/luci-base/po/pt-br/base.po3
-rw-r--r--modules/luci-base/po/pt/base.po3
-rw-r--r--modules/luci-base/po/ro/base.po3
-rw-r--r--modules/luci-base/po/ru/base.po3
-rw-r--r--modules/luci-base/po/sk/base.po3
-rw-r--r--modules/luci-base/po/sv/base.po3
-rw-r--r--modules/luci-base/po/templates/base.pot3
-rw-r--r--modules/luci-base/po/tr/base.po3
-rw-r--r--modules/luci-base/po/uk/base.po3
-rw-r--r--modules/luci-base/po/vi/base.po3
-rw-r--r--modules/luci-base/po/zh-cn/base.po35
-rw-r--r--modules/luci-base/po/zh-tw/base.po3
32 files changed, 132 insertions, 42 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index cc57ce8ee1..291789cb64 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -26,6 +26,7 @@ include $(INCLUDE_DIR)/host-build.mk
define Package/luci-base/conffiles
/etc/luci-uploads
/etc/config/luci
+/etc/config/ucitrack
endef
include ../../luci.mk
diff --git a/modules/luci-base/htdocs/luci-static/resources/cbi.js b/modules/luci-base/htdocs/luci-static/resources/cbi.js
index 4be917d098..b819230cf3 100644
--- a/modules/luci-base/htdocs/luci-static/resources/cbi.js
+++ b/modules/luci-base/htdocs/luci-static/resources/cbi.js
@@ -481,8 +481,9 @@ function cbi_d_check(deps) {
istat = (istat && cbi_d_checkvalue(j, deps[i][j]))
}
}
- if (istat) {
- return !reverse;
+
+ if (istat ^ reverse) {
+ return true;
}
}
return def;
@@ -648,9 +649,6 @@ function cbi_combobox(id, values, def, man, focus) {
var dt = obj.getAttribute('cbi_datatype');
var op = obj.getAttribute('cbi_optional');
- if (dt)
- cbi_validate_field(sel, op == 'true', dt);
-
if (!values[obj.value]) {
if (obj.value == "") {
var optdef = document.createElement("option");
@@ -685,6 +683,9 @@ function cbi_combobox(id, values, def, man, focus) {
obj.style.display = "none";
+ if (dt)
+ cbi_validate_field(sel, op == 'true', dt);
+
cbi_bind(sel, "change", function() {
if (sel.selectedIndex == sel.options.length - 1) {
obj.style.display = "inline";
diff --git a/modules/luci-base/htdocs/luci-static/resources/xhr.js b/modules/luci-base/htdocs/luci-static/resources/xhr.js
index 701c12ac19..3385f8f230 100644
--- a/modules/luci-base/htdocs/luci-static/resources/xhr.js
+++ b/modules/luci-base/htdocs/luci-static/resources/xhr.js
@@ -91,8 +91,6 @@ XHR = function()
xhr.open('POST', url, true);
xhr.setRequestHeader('Content-type', 'application/x-www-form-urlencoded');
- xhr.setRequestHeader('Content-length', code.length);
- xhr.setRequestHeader('Connection', 'close');
xhr.send(code);
}
diff --git a/modules/luci-base/luasrc/dispatcher.lua b/modules/luci-base/luasrc/dispatcher.lua
index 1b684aa79c..e4f77f18d8 100644
--- a/modules/luci-base/luasrc/dispatcher.lua
+++ b/modules/luci-base/luasrc/dispatcher.lua
@@ -219,10 +219,19 @@ function dispatch(request)
local lang = conf.main.lang or "auto"
if lang == "auto" then
local aclang = http.getenv("HTTP_ACCEPT_LANGUAGE") or ""
- for lpat in aclang:gmatch("[%w-]+") do
- lpat = lpat and lpat:gsub("-", "_")
- if conf.languages[lpat] then
- lang = lpat
+ for aclang in aclang:gmatch("[%w_-]+") do
+ local country, culture = aclang:match("^([a-z][a-z])[_-]([a-zA-Z][a-zA-Z])$")
+ if country and culture then
+ local cc = "%s_%s" %{ country, culture:lower() }
+ if conf.languages[cc] then
+ lang = cc
+ break
+ elseif conf.languages[country] then
+ lang = country
+ break
+ end
+ elseif conf.languages[aclang] then
+ lang = aclang
break
end
end
diff --git a/modules/luci-base/luasrc/sys.lua b/modules/luci-base/luasrc/sys.lua
index 99f3ee2919..115c54d54a 100644
--- a/modules/luci-base/luasrc/sys.lua
+++ b/modules/luci-base/luasrc/sys.lua
@@ -348,8 +348,10 @@ end
function net.devices()
local devs = {}
+ local seen = {}
for k, v in ipairs(nixio.getifaddrs()) do
- if v.family == "packet" then
+ if v.name and not seen[v.name] then
+ seen[v.name] = true
devs[#devs+1] = v.name
end
end
diff --git a/modules/luci-base/po/ca/base.po b/modules/luci-base/po/ca/base.po
index 9f4efdd1f1..0486ec2502 100644
--- a/modules/luci-base/po/ca/base.po
+++ b/modules/luci-base/po/ca/base.po
@@ -2342,6 +2342,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "La contrasenya s'ha canviat amb èxit!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Ruta als Certificats CA"
diff --git a/modules/luci-base/po/cs/base.po b/modules/luci-base/po/cs/base.po
index 9efe3b7d8e..c217b0c394 100644
--- a/modules/luci-base/po/cs/base.po
+++ b/modules/luci-base/po/cs/base.po
@@ -2365,6 +2365,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "Heslo bylo úspěšně změněno!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Cesta k certifikátu CA"
diff --git a/modules/luci-base/po/de/base.po b/modules/luci-base/po/de/base.po
index fa26a1d72e..183e495a22 100644
--- a/modules/luci-base/po/de/base.po
+++ b/modules/luci-base/po/de/base.po
@@ -2427,6 +2427,9 @@ msgstr "Password des inneren, privaten Schlüssels"
msgid "Password successfully changed!"
msgstr "Passwort erfolgreich geändert!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Pfad zum CA-Zertifikat"
diff --git a/modules/luci-base/po/el/base.po b/modules/luci-base/po/el/base.po
index e3969afff0..b385651f34 100644
--- a/modules/luci-base/po/el/base.po
+++ b/modules/luci-base/po/el/base.po
@@ -2372,6 +2372,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "Ο κωδικός πρόσβασης άλλαξε επιτυχώς!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Διαδρομή για Πιστοποιητικό CA"
diff --git a/modules/luci-base/po/en/base.po b/modules/luci-base/po/en/base.po
index 6537370156..04207336e3 100644
--- a/modules/luci-base/po/en/base.po
+++ b/modules/luci-base/po/en/base.po
@@ -2339,6 +2339,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr ""
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Path to CA-Certificate"
diff --git a/modules/luci-base/po/es/base.po b/modules/luci-base/po/es/base.po
index a3476735b5..626e374b45 100644
--- a/modules/luci-base/po/es/base.po
+++ b/modules/luci-base/po/es/base.po
@@ -2379,6 +2379,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "¡Contraseña cambiada!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Ruta al Certificado CA"
diff --git a/modules/luci-base/po/fr/base.po b/modules/luci-base/po/fr/base.po
index 1aab5cb9a4..b0b4b4334c 100644
--- a/modules/luci-base/po/fr/base.po
+++ b/modules/luci-base/po/fr/base.po
@@ -2392,6 +2392,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "Mot de passe changé avec succès !"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Chemin de la CA"
diff --git a/modules/luci-base/po/he/base.po b/modules/luci-base/po/he/base.po
index d8eae1f84f..2c2c5d27ec 100644
--- a/modules/luci-base/po/he/base.po
+++ b/modules/luci-base/po/he/base.po
@@ -2306,6 +2306,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr ""
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr ""
diff --git a/modules/luci-base/po/hu/base.po b/modules/luci-base/po/hu/base.po
index dfed45de59..8f5aee4c78 100644
--- a/modules/luci-base/po/hu/base.po
+++ b/modules/luci-base/po/hu/base.po
@@ -2382,6 +2382,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "A jelszó megváltoztatása sikeres!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "CA tanúsítvány elérési útja"
diff --git a/modules/luci-base/po/it/base.po b/modules/luci-base/po/it/base.po
index 04331ab75d..ea7578e612 100644
--- a/modules/luci-base/po/it/base.po
+++ b/modules/luci-base/po/it/base.po
@@ -2378,6 +2378,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "Password cambiata con successo!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Percorso al certificato CA"
diff --git a/modules/luci-base/po/ja/base.po b/modules/luci-base/po/ja/base.po
index 714b064dcb..7d23abede2 100644
--- a/modules/luci-base/po/ja/base.po
+++ b/modules/luci-base/po/ja/base.po
@@ -3,14 +3,14 @@ msgstr ""
"Project-Id-Version: \n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2009-06-10 03:40+0200\n"
-"PO-Revision-Date: 2017-04-03 02:32+0900\n"
+"PO-Revision-Date: 2017-07-28 12:17+0900\n"
"Last-Translator: INAGAKI Hiroshi <musashino.open@gmail.com>\n"
"Language: ja\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=1; plural=0;\n"
-"X-Generator: Poedit 2.0\n"
+"X-Generator: Poedit 2.0.3\n"
"Language-Team: \n"
msgid "%s is untagged in multiple VLANs!"
@@ -44,7 +44,7 @@ msgid "-- match by label --"
msgstr "-- ラベルを指定 --"
msgid "-- match by uuid --"
-msgstr "-- UUIDを指定 --"
+msgstr "-- UUID を指定 --"
msgid "1 Minute Load:"
msgstr "過去1分の負荷:"
@@ -157,6 +157,8 @@ msgid ""
"<br/>Note: you need to manually restart the cron service if the crontab file "
"was empty before editing."
msgstr ""
+"<br />注意: 編集前の crontab ファイルが空の場合、手動で cron サービスの再起動"
+"を行う必要があります。"
msgid "A43C + J43 + A43"
msgstr ""
@@ -283,7 +285,7 @@ msgid "Allocate IP sequentially"
msgstr ""
msgid "Allow <abbr title=\"Secure Shell\">SSH</abbr> password authentication"
-msgstr "<abbr title=\"Secure Shell\">SSH</abbr> パスワード認証を許可します"
+msgstr "<abbr title=\"Secure Shell\">SSH</abbr> パスワード認証を許可します。"
msgid "Allow all except listed"
msgstr "リスト内の端末からのアクセスを禁止"
@@ -299,10 +301,10 @@ msgstr ""
"リモートホストがSSH転送されたローカルのポートに接続することを許可します"
msgid "Allow root logins with password"
-msgstr "パスワードを使用したroot権限でのログインを許可する"
+msgstr "パスワードでの root ログインを許可"
msgid "Allow the <em>root</em> user to login with password"
-msgstr "パスワードを使用した<em>root</em>権限でのログインを許可する"
+msgstr "パスワードを使用した <em>root</em> 権限でのログインを許可します。"
msgid ""
"Allow upstream responses in the 127.0.0.0/8 range, e.g. for RBL services"
@@ -515,8 +517,8 @@ msgid ""
"defined backup patterns."
msgstr ""
"以下は、バックアップの際に含まれるファイルのリストです。このリストは、opkgに"
-"よって認識されている設定ファイル、重要なベースファイル、ユーザーが設定した正"
-"規表現に一致したファイルの一覧です。"
+"よって認識されている設定ファイル、重要なベースファイル、ユーザーが設定したパ"
+"ターンに一致したファイルの一覧です。"
msgid "Bind interface"
msgstr ""
@@ -858,7 +860,7 @@ msgid "Device is rebooting..."
msgstr "デバイスを再起動中です..."
msgid "Device unreachable"
-msgstr ""
+msgstr "デバイスに到達できません"
msgid "Diagnostics"
msgstr "診断機能"
@@ -1217,7 +1219,7 @@ msgid "Force TKIP and CCMP (AES)"
msgstr "TKIP 及びCCMP (AES) を使用"
msgid "Force link"
-msgstr ""
+msgstr "強制リンク"
msgid "Force use of NAT-T"
msgstr "NAT-Tの強制使用"
@@ -1467,7 +1469,7 @@ msgid "IPv6 routed prefix"
msgstr ""
msgid "IPv6 suffix"
-msgstr ""
+msgstr "IPv6 サフィックス"
msgid "IPv6-Address"
msgstr "IPv6-アドレス"
@@ -2380,6 +2382,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "パスワードを変更しました"
+msgid "Password2"
+msgstr "パスワード2"
+
msgid "Path to CA-Certificate"
msgstr "CA証明書のパス"
@@ -3672,7 +3677,7 @@ msgid "Waiting for command to complete..."
msgstr "コマンド実行中です..."
msgid "Waiting for device..."
-msgstr "デバイスの起動をお待ちください..."
+msgstr "デバイスの起動を待っています..."
msgid "Warning"
msgstr "警告"
diff --git a/modules/luci-base/po/ko/base.po b/modules/luci-base/po/ko/base.po
index 587b4890af..770a49cc5e 100644
--- a/modules/luci-base/po/ko/base.po
+++ b/modules/luci-base/po/ko/base.po
@@ -2332,6 +2332,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr ""
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr ""
diff --git a/modules/luci-base/po/ms/base.po b/modules/luci-base/po/ms/base.po
index 97912183f6..c2f62721d1 100644
--- a/modules/luci-base/po/ms/base.po
+++ b/modules/luci-base/po/ms/base.po
@@ -2311,6 +2311,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr ""
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Path ke CA-Sijil"
diff --git a/modules/luci-base/po/no/base.po b/modules/luci-base/po/no/base.po
index 9e3df81f84..6a6e818681 100644
--- a/modules/luci-base/po/no/base.po
+++ b/modules/luci-base/po/no/base.po
@@ -2357,6 +2357,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "Passordet er endret!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Sti til CA-sertifikat"
diff --git a/modules/luci-base/po/pl/base.po b/modules/luci-base/po/pl/base.po
index 98067c8654..e36461615d 100644
--- a/modules/luci-base/po/pl/base.po
+++ b/modules/luci-base/po/pl/base.po
@@ -2401,6 +2401,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "Pomyślnie zmieniono hasło!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Ścieżka do certyfikatu CA"
diff --git a/modules/luci-base/po/pt-br/base.po b/modules/luci-base/po/pt-br/base.po
index f2ba57555f..87c32bff92 100644
--- a/modules/luci-base/po/pt-br/base.po
+++ b/modules/luci-base/po/pt-br/base.po
@@ -2497,6 +2497,9 @@ msgstr "Senha da Chave Privada interna"
msgid "Password successfully changed!"
msgstr "A senha foi alterada com sucesso!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Caminho para o Certificado da AC"
diff --git a/modules/luci-base/po/pt/base.po b/modules/luci-base/po/pt/base.po
index cb90df5435..bea93f5c38 100644
--- a/modules/luci-base/po/pt/base.po
+++ b/modules/luci-base/po/pt/base.po
@@ -2379,6 +2379,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "Password alterada com sucesso!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Directorio do Certificado CA"
diff --git a/modules/luci-base/po/ro/base.po b/modules/luci-base/po/ro/base.po
index d51f4d05cb..2ee8537ac8 100644
--- a/modules/luci-base/po/ro/base.po
+++ b/modules/luci-base/po/ro/base.po
@@ -2303,6 +2303,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "Parola schimbata cu succes !"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Calea catre certificatul CA"
diff --git a/modules/luci-base/po/ru/base.po b/modules/luci-base/po/ru/base.po
index d30c643fce..6515772620 100644
--- a/modules/luci-base/po/ru/base.po
+++ b/modules/luci-base/po/ru/base.po
@@ -2387,6 +2387,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "Пароль успешно изменён!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Путь к центру сертификации"
diff --git a/modules/luci-base/po/sk/base.po b/modules/luci-base/po/sk/base.po
index f4037ea351..ab876ce326 100644
--- a/modules/luci-base/po/sk/base.po
+++ b/modules/luci-base/po/sk/base.po
@@ -2278,6 +2278,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr ""
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr ""
diff --git a/modules/luci-base/po/sv/base.po b/modules/luci-base/po/sv/base.po
index 6af6d610f2..803ac28196 100644
--- a/modules/luci-base/po/sv/base.po
+++ b/modules/luci-base/po/sv/base.po
@@ -2284,6 +2284,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr ""
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr ""
diff --git a/modules/luci-base/po/templates/base.pot b/modules/luci-base/po/templates/base.pot
index d3fc6a7324..1aa1816c20 100644
--- a/modules/luci-base/po/templates/base.pot
+++ b/modules/luci-base/po/templates/base.pot
@@ -2271,6 +2271,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr ""
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr ""
diff --git a/modules/luci-base/po/tr/base.po b/modules/luci-base/po/tr/base.po
index afabfa29d4..3c814cd30f 100644
--- a/modules/luci-base/po/tr/base.po
+++ b/modules/luci-base/po/tr/base.po
@@ -2291,6 +2291,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr ""
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr ""
diff --git a/modules/luci-base/po/uk/base.po b/modules/luci-base/po/uk/base.po
index 7ee06885ff..83e5501963 100644
--- a/modules/luci-base/po/uk/base.po
+++ b/modules/luci-base/po/uk/base.po
@@ -2398,6 +2398,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "Пароль успішно змінено!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Шлях до центру сертифікції"
diff --git a/modules/luci-base/po/vi/base.po b/modules/luci-base/po/vi/base.po
index 239e1c251d..7bd7868cf4 100644
--- a/modules/luci-base/po/vi/base.po
+++ b/modules/luci-base/po/vi/base.po
@@ -2314,6 +2314,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr ""
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "Đường dẫn tới CA-Certificate"
diff --git a/modules/luci-base/po/zh-cn/base.po b/modules/luci-base/po/zh-cn/base.po
index 7f4918557e..0ea00ff28d 100644
--- a/modules/luci-base/po/zh-cn/base.po
+++ b/modules/luci-base/po/zh-cn/base.po
@@ -7,7 +7,7 @@ msgid "%s is untagged in multiple VLANs!"
msgstr "%s 在多个 VLAN 中均未关联!"
msgid "(%d minute window, %d second interval)"
-msgstr "(%d 分钟信息,每 %d 秒刷新)"
+msgstr "(最近 %d 分钟信息,每 %d 秒刷新)"
msgid "(%s available)"
msgstr "(%s 可用)"
@@ -85,8 +85,8 @@ msgid ""
"<abbr title=\"Domain Name System\">DNS</abbr> servers will be queried in the "
"order of the resolvfile"
msgstr ""
-"按照 resolvfile 里的顺序查询 <abbr title=\"Domain Name System\">DNS</abbr> 服"
-"务器"
+"按照“解析文件”里的顺序查询 <abbr title=\"Domain Name System\">DNS</abbr> 服务"
+"器"
msgid "<abbr title=\"Extended Service Set Identifier\">ESSID</abbr>"
msgstr "<abbr title=\"Extended Service Set Identifier\">ESSID</abbr>"
@@ -620,7 +620,7 @@ msgid "Client"
msgstr "客户端 Client"
msgid "Client ID to send when requesting DHCP"
-msgstr "请求 DHCP 时发送的客户 ID"
+msgstr "请求 DHCP 时发送的客户端 ID"
msgid ""
"Close inactive connection after the given amount of seconds, use 0 to "
@@ -710,8 +710,7 @@ msgstr "自定义软件源"
msgid ""
"Customizes the behaviour of the device <abbr title=\"Light Emitting Diode"
"\">LED</abbr>s if possible."
-msgstr ""
-"自定义设备 <abbr title=\"Light Emitting Diode\">LED</abbr> 行为(如果可能)。"
+msgstr "自定义此设备的 <abbr title=\"Light Emitting Diode\">LED</abbr> 行为。"
msgid "DHCP Leases"
msgstr "DHCP 分配"
@@ -1015,10 +1014,10 @@ msgid "Enable the DF (Don't Fragment) flag of the encapsulating packets."
msgstr "启用后报文的 DF(禁止分片)标志。"
msgid "Enable this mount"
-msgstr "启用挂载点"
+msgstr "启用此挂载点"
msgid "Enable this swap"
-msgstr "启用交换区"
+msgstr "启用此 swap 分区"
msgid "Enable/Disable"
msgstr "启用/禁用"
@@ -1477,8 +1476,8 @@ msgid ""
msgstr ""
"如果物理内存不足,闲置数据可自动移到 swap 区暂存,以增加可用的 <abbr title="
"\"Random Access Memory\">RAM</abbr>。请注意:swap 区的数据处理会非常慢,因为 "
-"swap设备无法像 <abbr title=\"Random Access Memory\">RAM</abbr> 这样的高速率访"
-"问。"
+"swap 设备无法像 <abbr title=\"Random Access Memory\">RAM</abbr> 这样的高速率"
+"访问。"
msgid "Ignore <code>/etc/hosts</code>"
msgstr "忽略 <code>/etc/hosts</code>"
@@ -2794,10 +2793,10 @@ msgid "Scheduled Tasks"
msgstr "计划任务"
msgid "Section added"
-msgstr "添加的区域"
+msgstr "添加的节点"
msgid "Section removed"
-msgstr "移除的区域"
+msgstr "移除的节点"
msgid "See \"mount\" manpage for details"
msgstr "详参 \"mount\" 联机帮助"
@@ -3124,7 +3123,7 @@ msgid ""
"\">e.g.</abbr> <samp><abbr title=\"Third Extended Filesystem\">ext3</abbr></"
"samp>)"
msgstr ""
-"用于格式化存储器的文件系统,(例如:<samp><abbr title=\"Third Extended "
+"用于格式化存储器的文件系统(例如:<samp><abbr title=\"Third Extended "
"Filesystem\">ext3</abbr></samp>)"
msgid ""
@@ -3142,7 +3141,7 @@ msgid "The following changes have been reverted"
msgstr "以下更改已放弃"
msgid "The following rules are currently active on this system."
-msgstr "系统中的活跃连接。"
+msgstr "以下规则当前在系统中处于活动状态。"
msgid "The given network name is not unique"
msgstr "给定的网络名重复"
@@ -3185,7 +3184,7 @@ msgstr "提交的安全令牌无效或已过期!"
msgid ""
"The system is erasing the configuration partition now and will reboot itself "
"when finished."
-msgstr "系统正在删除配置分区,完成后会自动重启。"
+msgstr "系统正在擦除配置分区,完成后会自动重启。"
msgid ""
"The system is flashing now.<br /> DO NOT POWER OFF THE DEVICE!<br /> Wait a "
@@ -3204,7 +3203,7 @@ msgstr "隧道端点在 NAT 之后,默认为禁用,仅适用于 AYIYA"
msgid ""
"The uploaded image file does not contain a supported format. Make sure that "
"you choose the generic image format for your platform."
-msgstr "不支持所上传的文件格式。请确认选择的文件无误。"
+msgstr "不支持所上传的映像文件格式,请选择适合当前平台的通用映像文件。"
msgid "There are no active leases."
msgstr "没有已分配的租约。"
@@ -3286,7 +3285,7 @@ msgstr "这通常是隧道代理所管理的最近的 PoP 的地址"
msgid ""
"This list gives an overview over currently running system processes and "
"their status."
-msgstr "系统中正在运行的进程和其状态信息。"
+msgstr "系统中正在运行的进程概况和它们的状态信息。"
msgid "This page allows the configuration of custom button actions"
msgstr "自定义按键动作。"
@@ -3318,7 +3317,7 @@ msgid "Total Available"
msgstr "可用数"
msgid "Traceroute"
-msgstr "路由追踪"
+msgstr "Traceroute"
msgid "Traffic"
msgstr "流量"
diff --git a/modules/luci-base/po/zh-tw/base.po b/modules/luci-base/po/zh-tw/base.po
index 7521324f1c..7b2792e61f 100644
--- a/modules/luci-base/po/zh-tw/base.po
+++ b/modules/luci-base/po/zh-tw/base.po
@@ -2319,6 +2319,9 @@ msgstr ""
msgid "Password successfully changed!"
msgstr "密碼已變更成功!"
+msgid "Password2"
+msgstr ""
+
msgid "Path to CA-Certificate"
msgstr "CA-證書的路徑"