summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'modules/luci-base/src/Makefile')
-rw-r--r--modules/luci-base/src/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/luci-base/src/Makefile b/modules/luci-base/src/Makefile
new file mode 100644
index 000000000..7bb7f2ebe
--- /dev/null
+++ b/modules/luci-base/src/Makefile
@@ -0,0 +1,21 @@
+%.o: %.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(FPIC) -c -o $@ $<
+
+clean:
+ rm -f po2lmo parser.so version.lua *.o
+
+po2lmo: po2lmo.o template_lmo.o
+ $(CC) $(LDFLAGS) -o $@ $^
+
+parser.so: template_parser.o template_utils.o template_lmo.o template_lualib.o
+ $(CC) $(LDFLAGS) -shared -o $@ $^
+
+version.lua:
+ ./mkversion.sh $@ $(LUCI_VERSION)
+
+compile: parser.so version.lua
+
+install: compile
+ mkdir -p $(DESTDIR)/usr/lib/lua/luci/template
+ cp parser.so $(DESTDIR)/usr/lib/lua/luci/template/parser.so
+ cp version.lua $(DESTDIR)/usr/lib/lua/luci/version.lua