summaryrefslogtreecommitdiffhomepage
path: root/modules/luci-base/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'modules/luci-base/Makefile')
-rw-r--r--modules/luci-base/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index 06ee7985e..9bc8ec17a 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -36,13 +36,14 @@ define Host/Configure
endef
define Host/Compile
- $(MAKE) -C src/ clean po2lmo
+ $(MAKE) -C src/ clean po2lmo jsmin
endef
define Host/Install
$(INSTALL_DIR) $(1)/bin
$(INSTALL_DIR) $(1)/lib/lua/5.1
$(INSTALL_BIN) src/po2lmo $(1)/bin/po2lmo
+ $(INSTALL_BIN) src/jsmin $(1)/bin/jsmin
$(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/luasrcdiet $(1)/bin/luasrcdiet
$(CP) $(HOST_BUILD_DIR)/luasrcdiet $(1)/lib/lua/5.1/
endef