diff options
Diffstat (limited to 'luci.mk')
-rw-r--r-- | luci.mk | 13 |
1 files changed, 2 insertions, 11 deletions
@@ -221,25 +221,16 @@ define Package/$(PKG_NAME)/install else true; fi endef -ifneq ($(LUCI_DEFAULTS),) +ifndef Package/$(PKG_NAME)/postinst define Package/$(PKG_NAME)/postinst [ -n "$${IPKG_INSTROOT}" ] || {$(foreach script,$(LUCI_DEFAULTS), (. /etc/uci-defaults/$(script)) && rm -f /etc/uci-defaults/$(script)) rm -f /tmp/luci-indexcache rm -rf /tmp/luci-modulecache/ + killall -HUP rpcd 2>/dev/null exit 0 } endef -else -ifndef Package/$(PKG_NAME)/postinst -define Package/$(PKG_NAME)/postinst -[ -n "$${IPKG_INSTROOT}" ] || { - rm -f /tmp/luci-indexcache - rm -rf /tmp/luci-modulecache/ - exit 0 -} -endef -endif endif |