summaryrefslogtreecommitdiffhomepage
path: root/luci.mk
diff options
context:
space:
mode:
Diffstat (limited to 'luci.mk')
-rw-r--r--luci.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/luci.mk b/luci.mk
index 12e9b02ef2..1efae9a1fb 100644
--- a/luci.mk
+++ b/luci.mk
@@ -98,7 +98,7 @@ ifeq ($(PKG_NAME),luci-base)
menu "Translations"$(foreach lang,$(LUCI_LANGUAGES),
config LUCI_LANG_$(lang)
- bool "$(shell echo '$(LUCI_LANG.$(lang))' | sed -e 's/^.* (\(.*\))$$/\1/') ($(lang))")
+ tristate "$(shell echo '$(LUCI_LANG.$(lang))' | sed -e 's/^.* (\(.*\))$$/\1/') ($(lang))")
endmenu
endef
@@ -179,6 +179,7 @@ define LuciTranslation
CATEGORY:=LuCI
TITLE:=$(PKG_NAME) - $(1) translation
HIDDEN:=1
+ DEFAULT:=m if ALL||LUCI_LANG_$(1)
endef
define Package/luci-i18n-$(LUCI_BASENAME)-$(1)/install