summaryrefslogtreecommitdiffhomepage
path: root/luci.mk
diff options
context:
space:
mode:
Diffstat (limited to 'luci.mk')
-rw-r--r--luci.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/luci.mk b/luci.mk
index 84d151230..eb034d208 100644
--- a/luci.mk
+++ b/luci.mk
@@ -150,7 +150,8 @@ LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci
define SrcDiet
$(FIND) $(1) -type f -name '*.lua' | while read src; do \
- if LuaSrcDiet --noopt-binequiv -o "$$$$src.o" "$$$$src"; \
+ if $(STAGING_DIR)/host/bin/lua $(STAGING_DIR)/host/bin/LuaSrcDiet \
+ --noopt-binequiv -o "$$$$src.o" "$$$$src"; \
then mv "$$$$src.o" "$$$$src"; fi; \
done
endef