summaryrefslogtreecommitdiffhomepage
path: root/libs
diff options
context:
space:
mode:
Diffstat (limited to 'libs')
-rw-r--r--libs/sgi-webuci/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/libs/sgi-webuci/Makefile b/libs/sgi-webuci/Makefile
index c679710b67..c7f70eb5c8 100644
--- a/libs/sgi-webuci/Makefile
+++ b/libs/sgi-webuci/Makefile
@@ -24,7 +24,7 @@ $(BOA_DIR)/.prepared: $(BOA_FILE)
$(BOA_DIR)/.patched: $(BOA_DIR)/.prepared $(BOA_PATCHDIR)/series
(cd $(BOA_DIR); \
if [ -x "$$(which quilt 2>/dev/null)" ]; then \
- quilt push -a; \
+ [ "$$(quilt top 2>/dev/null)" = "$$(tail -n1 patches/series)" ] || quilt push -a; \
else \
cat patches/*.patch | patch -p1; \
fi; \